summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 10 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b3a98c6614b9..a60a33b24fa9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname='subtitld'
pkgver=23.02
-pkgrel=2
+pkgrel=3
pkgdesc='Subtitld: An open source software to create, edit and transcribe subtitles'
arch=('any')
url='https://www.subtitld.org/'
@@ -15,8 +15,15 @@ depends=('python' 'pyside6' 'python-pyffms2' 'python-mpv'
'python-beautifulsoup4' 'python-lxml' 'python-six' 'python-chardet'
'hicolor-icon-theme'
)
-source=("https://gitlab.com/jonata/$pkgname/-/archive/$pkgver/${pkgname}-${pkgver}.tar.gz")
-sha256sums=('83381cd697fa4355bc0d4689dfc063efe9ec41c8e177b8e55e35b7b4e6af3ace')
+source=("https://gitlab.com/jonata/$pkgname/-/archive/$pkgver/${pkgname}-${pkgver}.tar.gz"
+ "remove-gpu-hwdec-interop.patch")
+sha256sums=('83381cd697fa4355bc0d4689dfc063efe9ec41c8e177b8e55e35b7b4e6af3ace'
+ 'fe4288ee0bbde13e4cf20f9c55c7bc973e8928fd37da50b2c05038205ecf20d5')
+
+prepare() {
+ cd ${pkgname}-${pkgver}/
+ patch -p1 < ../remove-gpu-hwdec-interop.patch
+}
build() {
cd ${pkgname}-${pkgver}/