summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 43caf5278fa0..9acd80e656ad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,14 @@
pkgname=sucks
pkgver=0.8.1
-pkgrel=1
+pkgrel=2
pkgdesc="Simple command-line script for the Ecovacs series of robot vacuums"
arch=(any)
url="https://github.com/wpietri/sucks"
license=('GPL')
depends=('python' 'python-sleekxmpp' 'python-click' 'python-requests' 'python-pycryptodome' 'python-pycountry-convert')
checkdepends=('python-nose' 'python-requests-mock')
+optdepends=('bash-completion')
backup=()
source=("${url}/archive/v${pkgver}.tar.gz")
sha512sums=('45b64b65a9fe012cb8f59757ce6ae5e94822f4621c0f165e0782007d8fc8be6974d3aa6a5f5feee0cf8dbb2ca08a5e79315ae933791004fa90ce5bd228c797b7')
@@ -21,4 +22,5 @@ check() {
package() {
install -Dm755 $pkgname-$pkgver/sucks.py $pkgdir/usr/bin/sucks
sed -i '1i #!/usr/bin/python' $pkgdir/usr/bin/sucks
+ _SUCKS_COMPLETE=source sucks | install -Dm644 /dev/stdin $pkgdir/usr/share/bash-completion/completions/sucks
}