summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 11 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b2da3a7e67d0..e5431f60bcde 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,11 +5,14 @@
# SELinux Maintainer: Nicolas Iooss (nicolas <dot> iooss <at> m4x <dot> org)
# SELinux Contributor: Timothée Ravier <tim@siosm.fr>
# SELinux Contributor: Nicky726 <Nicky726@gmail.com>
+#
+# This PKGBUILD is maintained on https://github.com/archlinuxhardened/selinux.
+# If you want to help keep it up to date, please open a Pull Request there.
pkgname=sudo-selinux
-_sudover=1.8.22
+_sudover=1.8.23
pkgver=${_sudover/p/.p}
-pkgrel=1
+pkgrel=2
pkgdesc="Give certain users the ability to run some commands as root - SELinux support"
arch=('x86_64')
url="https://www.sudo.ws/sudo/"
@@ -22,14 +25,19 @@ provides=("${pkgname/-selinux}=${pkgver}-${pkgrel}"
backup=('etc/sudoers' 'etc/pam.d/sudo')
install=${pkgname/-selinux}.install
source=(https://www.sudo.ws/sudo/dist/${pkgname/-selinux}-$_sudover.tar.gz{,.sig}
+ allow-preserve-env-with-arg.patch
sudo.pam)
-sha256sums=('7256cb27c20883b14360eddbd17f98922073d104b214cf65aeacf1d9c9b9fd02'
+sha256sums=('d863d29b6fc87bc784a3223350e2b28a2ff2c4738f0fb8f1c92bb38c3017e679'
'SKIP'
+ '439edd65dbc0115794dec833968c538c98a275522ec9a2e0ac3d4a9eb9cc3b33'
'd1738818070684a5d2c9b26224906aad69a4fea77aabd960fc2675aee2df1fa2')
validpgpkeys=('59D1E9CCBA2B376704FDD35BA9F4C021CEA470FB')
prepare() {
cd "$srcdir/${pkgname/-selinux}-$_sudover"
+
+ # https://bugzilla.sudo.ws/show_bug.cgi?id=835
+ patch -Np1 -i ../allow-preserve-env-with-arg.patch
}
build() {