summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 31 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 067fa0a2aa71..02cdc1ce230e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -93,8 +93,9 @@ set -u
# http://wiki.linuxcnc.org/cgi-bin/wiki.pl?Startech
pkgname='sunix-snx'
#pkgver='2.0.4_2'; _dl='2016/20160706173626'
-pkgver='2.0.4_3'; _dl='2017/20171122180114'
-pkgrel='3'
+#pkgver='2.0.4_3'; _dl='2017/20171122180114'
+pkgver='2.0.5_0'; _dl='2021/20210407180737'
+pkgrel='1'
pkgdesc='kernel module driver for Sunix SUN1889 SUN1989 SUN1999 SUN2212 SUN2410 UL7502AQ UL7512EQ UL7522EQ PCI PCIe multi I/O parallel serial RS-232 422 485 port Dell Lenovo Acer Startech'
arch=('i686' 'x86_64')
url='http://www.sunix.com/'
@@ -106,16 +107,26 @@ makedepends=('gzip' 'findutils' 'sed' 'diffutils' 'patch')
install="${pkgname}-install.sh"
_srcdir="snx_V${pkgver//_/.}"
source=(
- "http://www.sunix.com/en/download.php?file=driver&file_link=download/driver/${_dl}_snx_V${pkgver//_/.}.tar.gz"
+ # DO NOT switch link to https. It doesn't work.
+ "http://www.sunix.com/en/download.php?file=driver&file_link=download/driver/${_dl}_snx_V${pkgver//_/.}.tar.xz"
#"http://www.sunix.com.tw/en/download.php?pid=1479&file=driver&file_link=download/driver/${_dl}_snx_V${pkgver//_/.}.tar.gz"
# http://dpdk.org/dev/patchwork/patch/22003/ [dpdk-dev] kni: fix build with kernel 4.11 lib/librte_eal/linuxapp/kni/compat.h lib/librte_eal/linuxapp/kni/kni_dev.h
# http://dpdk.org/dev/patchwork/patch/22037/
# http://rglinuxtech.com/?p=1930
# https://forum.manjaro.org/t/error-with-rtl8812au/24066
- '0000-Kernel-4-15-timers.patch'
+ #'0000-Kernel-4-15-timers.patch'
+ '0001-kernel-4.7-async-initialized.patch'
+ '0002-kernel-5.12-tty-low_latency.patch'
+ '0003-kernel-5.14-task_struct.state-unsigned-tty-flow-tty.patch'
)
-sha256sums=('5103e25929f5d33a924be1fe1fc824a804fae9c80e3869417b5558ae31330756'
- 'eb9cb3cf971023442925b4eacdf8ac47b1b48172b30d8943312865aa92f19976')
+md5sums=('effaa874994bde6047afe2ea3e023cf6'
+ '71564d580faaf72ab3518c298883742e'
+ 'e3604145fb2b1678da395a600e4cf1ed'
+ 'a16e94419d504663c50d3d7522b0c019')
+sha256sums=('bfc5e68c0ef21266a11db62e3cd0bc3a523207afcf2bb989f2437caf86086d35'
+ '4ea9275ca8122543c25f17112d4c374dc39de32e3d9d1d0aa5488bacd514750d'
+ 'ab0ef161b7c7053299b18ab9b697047d37142e9e88d53d40ac087f64522a55dd'
+ '12a9d8f11c60cef0e70d0d5cba684146beb32eef76e7519728e2e4453f671251')
if [ "${_opt_DKMS}" -ne 0 ]; then
depends+=('linux' 'dkms' 'linux-headers')
@@ -180,9 +191,21 @@ prepare() {
sed -e 's:\r$::g' -i $(grep -slrF $'\r')
- #cp -pr "${srcdir}/${_srcdir}"{,.orig-0000}
+ #cp -pr "${srcdir}/${_srcdir}"{,.orig-0000}; false
#diff -pNaru5 snx_V2.0.4.3{.orig-0000,} > '0000-Kernel-4-15-timers.patch'
- patch -Nup1 -i "${srcdir}/0000-Kernel-4-15-timers.patch"
+ #patch -Nup1 -i "${srcdir}/0000-Kernel-4-15-timers.patch"
+
+ #cp -pr "${srcdir}/${_srcdir}"{,.orig-0000}; false
+ #diff -pNaru5 snx_V2.0.5.0{.orig-0000,} > '0001-kernel-4.7-async-initialized.patch'
+ patch -Nup1 -i "${srcdir}/0001-kernel-4.7-async-initialized.patch"
+
+ #cp -pr "${srcdir}/${_srcdir}"{,.orig-0000}; false
+ #diff -pNaru5 snx_V2.0.5.0{.orig-0000,} > '0002-kernel-5.12-tty-low_latency.patch'
+ patch -Nup1 -i "${srcdir}/0002-kernel-5.12-tty-low_latency.patch"
+
+ #cp -pr "${srcdir}/${_srcdir}"{,.orig-0000}; false
+ #diff -pNaru5 snx_V2.0.5.0{.orig-0000,} > '0003-kernel-5.14-task_struct.state-unsigned-tty-flow-tty.patch'
+ patch -Nup1 -i "${srcdir}/0003-kernel-5.14-task_struct.state-unsigned-tty-flow-tty.patch"
# Kernel 3,4,5 all use the same makefile. Trim out everything but Kernel 4
mv driver/Makefile{,.Arch}