summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 394e9aa93a87..ccc972686d10 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,21 @@
pkgname=sunloginclient
pkgver=10.0.2.24779
-pkgrel=3
+pkgrel=4
pkgdesc="Sunlogin Remote Control is a software that supports remote control of mobile devices, Windows, Mac, Linux and other systems. It is the best choice for IT technology, game players, designers and other people with remote management needs."
arch=("x86_64")
url="https://sunlogin.oray.com"
-depends=("libappindicator-gtk3" "webkitgtk" 'aspell' 'hspell' 'nuspell' 'libvoikko')
+depends=("libappindicator-gtk3" "webkitgtk" 'aspell' 'hspell' 'nuspell' 'libvoikko' 'xorg-xhost')
license=('custom:sunloginclient')
options=("!emptydirs" "!strip")
source=("http://download.oray.com/sunlogin/linux/SunloginClient-${pkgver}_amd64.deb"
- 'LICENSE::https://service.oray.com/question/1820.html')
+ 'LICENSE::https://service.oray.com/question/1820.html'
+ 'sunlogin-client-xhost.desktop')
install='sunloginclient.INSTALL'
backup=("etc/orayconfig.conf")
sha256sums=('da2a61d106c2cecce271c89cd182b162bce34018539e1ba431580c5bbe120252'
- 'SKIP')
+ 'SKIP'
+ '15abf7f89fe7d54112e083914740108a73b6b2cd9d942d49de4c7ccb66c3e30f')
package() {
bsdtar -xf data.tar.xz -C "${pkgdir}"
@@ -42,6 +44,9 @@ package() {
# 创建软链
install -dm755 "$pkgdir/usr/bin"
ln -s "/opt/sunlogin/bin/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+
+ # xhost +
+ install -Dm644 "${srcdir}/sunlogin-client-xhost.desktop" "${pkgdir}/etc/xdg/autostart/sunlogin-client-xhost.desktop"
# ugly hack
sed -i "s#/usr/local/sunlogin\x0#/opt/sunlogin\x0\x0\x0\x0\x0\x0\x0#g" "${pkgdir}/opt/sunlogin/bin/${pkgname}"