summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 14 insertions, 24 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 51d5b7035bee..50079c510938 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,25 @@
-# Maintainer: Kyle Keen <keenerd@gmail.com>
-# Contributor: Tom Vincent Tom Vincent <http://tlvince.com/contact>
+# Maintainer: éclairevoyant
pkgname=sunwait
-pkgver=0.8
-_pkgver=0-8
+pkgver=0.9.1
pkgrel=1
-url="http://www.risacher.org/sunwait/"
+url="https://www.risacher.org/sunwait/"
pkgdesc="A small C program for calculating sunrise and sunset times"
-arch=('i686' 'x86_64')
-license=('GPL')
-depends=('gcc-libs')
+arch=(i686 x86_64)
+license=(GPL3)
+depends=(glibc)
+source=("$pkgname-$pkgver.tar.gz::https://github.com/risacher/sunwait/archive/refs/tags/$pkgver.tar.gz")
+b2sums=('e623a4d0d05f09ae52671679d84ea6700f667f7629d80873930a36596dd19a9215e4fa62f107172d9e70614077059be6d864d01476651f6c18afa172f64f767d')
-# original version
-#pkgver=20041208
-#source=(http://www.risacher.org/sunwait/$pkgname-$pkgver.tar.gz)
-#md5sums=('957dbcb6d16cb8f3b1ead0687397b495')
-
-# newer fork
-source=("http://downloads.sourceforge.net/project/sunwait4windows/sunwait${_pkgver}.tar")
-md5sums=('97b062fb4adce37d4af59f5b42675fce')
+prepare() {
+ # respect CFLAGS, LDFLAGS
+ sed -i 's/FLAGS=/FLAGS+=/g' $pkgname-$pkgver/makefile
+}
build() {
- #cd "$srcdir/$pkgname-$pkgver"
- cd "$srcdir/$pkgname/$pkgver"
- make
+ make -C $pkgname-$pkgver
}
package() {
- #cd "$srcdir/$pkgname-$pkgver"
- cd "$srcdir/$pkgname/$pkgver"
- install -Dm755 "$pkgname" "$pkgdir/usr/bin/$pkgname"
+ install -Dm755 $pkgname-$pkgver/$pkgname -t "$pkgdir/usr/bin/"
}
-
-# vim:set ts=2 sw=2 et: