summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 12 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a8297e8f0499..d68092783b1b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,31 @@
# Contributor: twa022 <twa022 at gmail dot com>
pkgname=superpaper
-pkgver=2.1.0+32+g7d0b284
-pkgrel=2
+pkgver=2.2.0
+pkgrel=1
pkgdesc="Cross-platform multi monitor wallpaper manager"
arch=('any')
url="https://github.com/hhannine/Superpaper"
license=('MIT')
depends=('python-pillow>=7.0' 'python-screeninfo>=0.6.1' 'python-wxpython'
- 'python-system_hotkey>=1.0.2+10+9541587' 'python-xpybutil' 'python-numpy')
+ 'python-system_hotkey>=1.0.5' 'python-xpybutil' 'python-numpy')
makedepends=('python-build' 'python-installer' 'python-wheel' 'python-setuptools' 'git')
-_commit='7d0b28400cccafa57f7a43ca2342d73c3293ff92'
-source=("${pkgname}::git+https://github.com/hhannine/${pkgname^}#commit=${_commit}")
-sha256sums=('SKIP')
-#source=("${pkgname}-${pkgver}.tar.gz::https://github.com/hhannine/${pkgname^}/archive/v${pkgver}.tar.gz")
-#sha256sums=('1de27ea76b77731c6a6e0221450cd3913a2275399c553ae7c13557ca7c2f5c08')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/hhannine/${pkgname^}/archive/v${pkgver}.tar.gz"
+ 'rename_system_hotkey_dep.patch')
+sha256sums=('22781b33c8fc72b69df467a0998f28d6fd5bfe6c4f8ad4794e46d80fde0b1537'
+ '02bc7fb70c18c7292ee9cdac9be58e0954cdb03b07032ee9b5c567fe5ec4d5a5')
-pkgver() {
- cd "${srcdir}/${pkgname}"
- git describe --long --tags | sed -r "s/^v//;s/-/+/g"
+prepare() {
+ cd "${pkgname}-${pkgver}"
+ patch -Np2 -r- -i ../rename_system_hotkey_dep.patch
}
build() {
- cd "${srcdir}/${pkgname}"
+ cd "${pkgname}-${pkgver}"
python -m build -wn
}
package() {
- cd "${srcdir}/${pkgname}"
+ cd "${pkgname}-${pkgver}"
python -m installer -d "${pkgdir}" dist/*.whl
}