summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 14 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1a61d2789ef0..82455507e89f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,31 +2,38 @@
_pkgname=superpaper
pkgname=${_pkgname}-git
-pkgver=2.1.0+38+g0c502d3
+pkgver=2.2.0+2+g299f7e5
pkgrel=1
pkgdesc="Cross-platform multi monitor wallpaper manager"
arch=('any')
url="https://github.com/hhannine/Superpaper"
license=('MIT')
depends=('python-pillow>=7.0' 'python-screeninfo>=0.6.1' 'python-wxpython'
- 'python-system_hotkey>=1.0.2+10+9541587' 'python-xpybutil' 'python-numpy')
+ 'python-system_hotkey>=5' 'python-xpybutil' 'python-numpy')
makedepends=('python-build' 'python-installer' 'python-wheel' 'python-setuptools' 'git')
provides=("${_pkgname}=${pkgver%%+}")
conflicts=("${_pkgname}")
-source=("${_pkgname}::git+https://github.com/hhannine/${_pkgname^}")
-sha256sums=('SKIP')
+source=("${_pkgname}::git+https://github.com/hhannine/${_pkgname^}"
+ 'rename_system_hotkey_dep.patch')
+sha256sums=('SKIP'
+ '02bc7fb70c18c7292ee9cdac9be58e0954cdb03b07032ee9b5c567fe5ec4d5a5')
pkgver() {
- cd "${srcdir}/${_pkgname}"
+ cd "${_pkgname}"
git describe --long --tags | sed -r "s/^v//;s/-/+/g"
}
+prepare() {
+ cd "${_pkgname}"
+ patch -Np2 -r- -i ../rename_system_hotkey_dep.patch
+}
+
build() {
- cd "${srcdir}/${_pkgname}"
+ cd "${_pkgname}"
python -m build -wn
}
package() {
- cd "${srcdir}/${_pkgname}"
+ cd "${_pkgname}"
python -m installer -d "${pkgdir}" dist/*.whl
}