summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 32 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4df4c36a69f7..fc0a60b384fc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Patrick Bartels <p4ddy.b@gmail.com>
pkgname=supertux-git
-pkgver=6347.ad28273
+pkgver=7292.f24d3bc
pkgrel=1
pkgdesc="A classic 2D jump'n run sidescroller game in a style similar to the original SuperMario game"
url='http://supertux.lethargik.org/'
@@ -13,8 +13,23 @@ depends=(sdl2_image physfs openal libvorbis curl boost glew)
makedepends=(git cmake)
conflicts=(supertux)
provides=(supertux)
-source=('git+https://github.com/SuperTux/supertux')
-sha512sums=('SKIP')
+source=('git+https://github.com/SuperTux/supertux'
+ # submodules
+ 'git+https://github.com/SuperTux/data.git'
+ 'git+https://github.com/google/googletest.git'
+ 'git+https://github.com/SuperTux/physfs'
+ 'git+https://github.com/SuperTux/sexp-cpp.git'
+ 'git+https://github.com/albertodemichelis/squirrel.git'
+ 'git+https://github.com/SuperTux/tinygettext.git'
+ 'git+https://github.com/SuperTux/translations')
+sha512sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
pkgver() {
cd supertux
@@ -24,6 +39,16 @@ pkgver() {
prepare() {
cd supertux
+ git submodule init
+ git config submodule.data.url "${srcdir}"/data
+ git config submodule.external/googletest.url "${srcdir}"/googletest
+ git config submodule.external/physfs.url "${srcdir}"/physfs
+ git config submodule.external/sexp-cpp.url "${srcdir}"/sexp-cpp
+ git config submodule.external/squirrel.url "${srcdir}"/squirrel
+ git config submodule.external/tinygettext.url "${srcdir}"/tinygettext
+ git config submodule.translations.url "${srcdir}"/translations
+ git submodule update
+
sed -i '/curl\/types.h/d' src/addon/addon_manager.cpp
sed -i '1i#include <cstddef>' src/supertux/screen_manager.hpp
}
@@ -31,8 +56,12 @@ prepare() {
build() {
cd supertux
+ export CFLAGS+=" -fPIC"
+ export CXXFLAGS+=" -fPIC"
+
cmake . \
-DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DINSTALL_SUBDIR_BIN=bin
make