summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..24bc5228297d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Julio Diez <juliosddr@gmail.com>
+_pkgname=suscan
+pkgname="${_pkgname}-git"
+pkgver=0.1
+pkgrel=1
+pkgdesc="SUScan is a graphical signal analysis tool"
+arch=("any")
+url="https://github.com/BatchDrake/suscan"
+license=("GPL")
+depends=("soapysdr" "sigutils-git")
+provides=("suscan")
+conflicts=("suscan")
+source=(suscan::git+https://github.com/BatchDrake/suscan.git)
+md5sums=("SKIP")
+
+build() {
+ cd "$_pkgname"
+
+ autoreconf -fvi
+
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$_pkgname"
+
+ make DESTDIR="$pkgdir/" install
+}