summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..21c9012e86ee
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Flow
+
+pkgname=svfs
+pkgver=0.5.1
+pkgrel=1
+pkgdesc="The Swift Virtual File System for hubiC (ovh)"
+arch=('i686' 'x86_64')
+conflicts=("svfs-git")
+provides=("svfs")
+url='https://github.com/ovh/svfs'
+license=('BSD')
+depends=('fuse' 'ruby')
+makedepends=()
+source_x86_64=("https://github.com/ovh/svfs/releases/download/v${pkgver}/${pkgname}_${pkgver}_amd64.deb")
+source_i686=("https://github.com/ovh/svfs/releases/download/v${pkgver}/${pkgname}_${pkgver}_386.deb")
+md5sums_i686=('eb07ec1aea5462db4fe19382e0fbf106')
+md5sums_x86_64=('851ef4ccffa447de858350f7101c7852')
+
+package() {
+ cd "${srcdir}"
+ tar -xzf data.tar.gz -C "${srcdir}"
+ install -Dm755 "${srcdir}"/usr/local/bin/hubic-application "${pkgdir}"/usr/bin/hubic-application
+ install -Dm755 "${srcdir}"/usr/local/bin/svfs "${pkgdir}"/usr/bin/svfs
+ install -Dm755 "${srcdir}"/sbin/mount.svfs "${pkgdir}"/usr/bin/mount.svfs
+}