summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 22 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e347387e5d0b..de22fc5557d8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,33 @@
-# Maintainer: Dan Elkouby <streetwalkermc@gmail.com>
-# Contributor: Jerome Leclanche <jerome@leclan.ch>
-# Contributor: Alexander F. Rødseth <xyproto@archlinux.org>
+# Maintainer: novenary <streetwalkermc@gmail.com>
# Contributor: Brett Cornwall <ainola@archlinux.org>
+# Contributor: Maxim Baz <$pkgname at maximbaz dot com>
+# Contributor: Alexander F. Rødseth <xyproto@archlinux.org>
pkgname=sway9
-pkgver=1.4
+pkgver=1.7
epoch=1
-pkgrel=5
-_commit=8cbcdc245c8a215279711cc18fc9f2d0a2577933
+pkgrel=1
+_commit=8afad182dffe7b4dc68481a1fcb301e427c8b536
pkgdesc='Tiling Wayland compositor and replacement for the i3 window manager (personal build)'
arch=(x86_64)
-url='https://github.com/Streetwalrus/sway9'
+url='https://github.com/9ary/sway9'
license=(MIT)
-depends=(cairo gdk-pixbuf2 json-c pango pcre swaybg ttf-font wlroots)
+depends=(
+ 'cairo'
+ 'gdk-pixbuf2'
+ 'json-c'
+ 'pango'
+ 'polkit'
+ 'pcre'
+ 'swaybg'
+ 'ttf-font'
+ 'wlroots'
+)
makedepends=(git meson ninja scdoc setconf wayland-protocols)
provides=(sway)
conflicts=(sway)
backup=(etc/sway/config)
optdepends=(
- 'alacritty: Terminal emulator used by the default config'
'dmenu: Application launcher'
'grim: Screenshot utility'
'i3status: Status line'
@@ -28,17 +37,16 @@ optdepends=(
'swaylock: Screen locker'
'wallutils: Timed wallpapers'
'waybar: Highly customizable bar'
- 'xorg-server-xwayland: X11 support'
+ 'xorg-xwayland: X11 support'
)
-source=("git+https://github.com/Streetwalrus/$pkgname.git#commit=$_commit"
+source=("git+https://github.com/9ary/$pkgname.git#commit=$_commit"
"50-systemd-user.conf")
sha512sums=('SKIP'
- '57590bc0d14c87289a4a9cd67991c6a841e54244d2a6186b5da5a08e633de2e8631959fa8c77ede211b0a5f315d920f2c1350951a53d6f2e9e81859056cb3c9e')
-validpgpkeys=('9DDA3B9FA5D58DD5392C78E652CB6609B22DA89A') # Drew DeVault
+ 'c2b7d808f4231f318e03789015624fd4cf32b81434b15406570b4e144c0defc54e216d881447e6fd9fc18d7da608cccb61c32e0e1fab2f1fe2750acf812d3137')
build() {
mkdir -p build
- arch-meson build "$pkgname" -D werror=false -D b_ndebug=true
+ arch-meson build "$pkgname" -D sd-bus-provider=libsystemd -D werror=false -D b_ndebug=true
ninja -C build
}