summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 7 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ae288f8223ec..b21783920517 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,25 @@
# Maintainer: itsme <mymail@ishere.ru>
pkgname=swaylock-effects
-pkgver=1.6.4
-_pkgver=1.6-4
-pkgrel=2
+pkgver=1.7.0.0
+pkgrel=1
pkgdesc="A fancier screen locker for Wayland."
arch=('i686' 'x86_64' 'aarch64')
url="https://github.com/mortie/$pkgname"
license=('MIT')
depends=('libxkbcommon' 'cairo' 'gdk-pixbuf2' 'pam')
makedepends=('git' 'meson' 'ninja' 'scdoc' 'wayland' 'wayland-protocols')
-provides=('swaylock' 'swaylock-effects')
-conflicts=('swaylock' 'swaylock-effects-git')
-source=("https://github.com/mortie/$pkgname/archive/v$_pkgver.tar.gz")
-sha256sums=('4f82c9d875ce20f1d58227ef65db60aacccb3fb29ce67c0f744849da68e82b20')
+provides=('swaylock')
+source=("https://github.com/jirutka/$pkgname/archive/v$pkgver.tar.gz")
+sha256sums=('e94d79e189602694bedfbafb553ce3c6c976426e16f76d93bf7e226dc2876eb6')
build() {
- cd "$pkgname-$_pkgver"
+ cd "$pkgname-$pkgver"
meson build --prefix=/usr
ninja -C build
}
package() {
- cd "$pkgname-$_pkgver"
+ cd "$pkgname-$pkgver"
DESTDIR="$pkgdir" ninja -C build install
}