summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6d6afb15f1cd..16069629caeb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,6 @@
-pkgname=swconfig
-pkgver=20150806
+pkgname=swconfig-git
+_pkgname=swconfig
+pkgver=20150806.4.g43e2854
pkgrel=1
pkgdesc="project to package the swconfig utility from OpenWRT for archlinuxarm on BPi-R1"
url="https://github.com/rains31/swconfig"
@@ -10,16 +11,16 @@ provides=(${pkgname})
conflicts=(${pkgname})
options=()
arch=('armv7h')
-source=(git+https://github.com/rains31/${pkgname}.git)
+source=(git+https://github.com/rains31/${_pkgname}.git)
sha1sums=('SKIP')
pkgver() {
- cd "$srcdir/${pkgname}"
+ cd "$srcdir/${_pkgname}"
git describe --tags | sed 's/^v//;s/-/./g'
}
package() {
- cd "$srcdir/${pkgname}"
+ cd "$srcdir/${_pkgname}"
make install DESTDIR=$pkgdir
}