summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5f9391b760cf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Franco Masotti <franco dot masotti at student dot unife dot it>
+# Contributor: Franco Masotti <franco dot masotti at student dot unife dot it>
+pkgname=swish
+pkgver=r1124.071295b
+pkgrel=1
+pkgdesc="SWI-Prolog for SHaring: a SWI-Prolog web IDE"
+arch=('x86_64')
+url="https://github.com/SWI-Prolog/swish"
+license=('BSD')
+depends=('swi-prolog-devel')
+makedepends=('git'
+ 'bower'
+ 'sed')
+conflicts=('swish-cplint')
+install=.install
+source=('git+https://github.com/SWI-Prolog/swish#branch=master')
+md5sums=('SKIP')
+
+build() {
+ cd ${srcdir}/swish
+ bower --allow-root install
+ make src
+ # Patch
+ cp ../../run.pl .
+ cp ../../run.sh .
+}
+
+pkgver () {
+ cd ${srcdir}/swish
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+package() {
+ cd ${srcdir}
+ install -d "${pkgdir}"/usr/share/"${pkgname}"
+ install -d "${pkgdir}"/usr/bin
+ cp -r swish/* "${pkgdir}"/usr/share/"${pkgname}"
+ install -D -m644 swish/LICENSE "${pkgdir}"/usr/share/licenses/"${pkgname}"/LICENSE
+ install -D -m644 ../"${pkgname}".service ${pkgdir}/usr/lib/systemd/system/"${pkgname}".service
+ ln -s /usr/share/"${pkgname}"/run.sh "${pkgdir}"/usr/bin/"${pkgname}"
+}