summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 18 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 66efa28c0376..6b92c3b3ae23 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
pkgname=switchboard-git
-pkgver=r1211.cd4124e
+pkgver=2.4.0.r25.gb406b3d
pkgrel=1
pkgdesc='The Pantheon Control Center'
arch=('x86_64')
@@ -9,25 +9,31 @@ url='https://github.com/elementary/switchboard'
license=('GPL3')
groups=('pantheon-unstable')
depends=('clutter-gtk' 'glib2' 'glibc' 'gtk3' 'libgee'
- 'libgranite.so')
-makedepends=('git' 'granite-git' 'intltool' 'meson' 'vala')
-optdepends=('switchboard-plug-about-bzr: About plug'
- 'switchboard-plug-default-applications-bzr: Default applications plug'
- 'switchboard-plug-elementary-tweaks-bzr: Elementary tweaks plug'
- 'switchboard-plug-keyboard-bzr: Keyboard plug'
- 'switchboard-plug-pantheon-shell-bzr: Pantheon Shell plug'
- 'switchboard-plug-power-bzr: Power plug')
+ 'libgranite.so' 'libhandy1')
+makedepends=('git' 'granite' 'intltool' 'meson' 'vala')
+optdepends=('switchboard-plug-about-git: About plug'
+ 'switchboard-plug-default-applications-git: Default applications plug'
+ 'switchboard-plug-elementary-tweaks-git: Elementary tweaks plug'
+ 'switchboard-plug-keyboard-git: Keyboard plug'
+ 'switchboard-plug-pantheon-shell-git: Pantheon Shell plug'
+ 'switchboard-plug-power-git: Power plug')
provides=('switchboard' 'libswitchboard-2.0.so')
conflicts=('switchboard')
-source=('git+https://github.com/elementary/switchboard.git')
-sha256sums=('SKIP')
+source=('git+https://github.com/elementary/switchboard.git'
+ '0001-libhandy1-support.patch')
+sha256sums=('SKIP'
+ '0963caab95c40cb9e538316eb5da2bd6e0614d570d887db13f3ff76e78fa9ed4')
pkgver() {
cd switchboard
- echo "r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ cd switchboard
+ patch -Np1 -i ../0001-libhandy1-support.patch
+}
build() {
arch-meson switchboard build \
-Dlibunity='false'