summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 9 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 13de37203eec..6691263171da 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,21 @@
# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
pkgname=switchboard-plug-user-accounts
-pkgver=0.1.4
+pkgver=0.1.5
pkgrel=1
-pkgdesc='User Accounts plug for Switchboard'
+pkgdesc='Switchboard User Accounts Plug'
arch=('i686' 'x86_64')
-url='https://launchpad.net/switchboard-plug-useraccounts'
+url='https://github.com/elementary/switchboard-plug-useraccounts'
license=('GPL3')
groups=('pantheon')
depends=('accountsservice' 'cairo' 'gdk-pixbuf2' 'glib2' 'glibc'
'gnome-desktop' 'gtk3' 'libgee' 'libpwquality' 'polkit'
'libgranite.so' 'libswitchboard-2.0.so')
-makedepends=('cmake' 'switchboard' 'vala')
-source=("https://launchpad.net/switchboard-plug-useraccounts/loki/${pkgver}/+download/switchboard-plug-useraccounts-${pkgver}.tar.xz")
-sha256sums=('cf0c2cea9514f30f4c67ba7327c0f03c3f0bd3de063bb1c2789c412a6d1f6ad6')
+makedepends=('cmake' 'gobject-introspection' 'switchboard' 'vala')
+source=("switchboard-plug-user-accounts-${pkgver}.tar.gz::https://github.com/elementary/switchboard-plug-useraccounts/archive/${pkgver}.tar.gz")
+sha256sums=('4787134c1f99b17b8ab1671766e69841b6e704b9898d8e6dc6f54fc8e356b4e8')
prepare() {
- cd switchboard-plug-useraccounts-${pkgver}
-
if [[ -d build ]]; then
rm -rf build
fi
@@ -25,9 +23,9 @@ prepare() {
}
build() {
- cd switchboard-plug-useraccounts-${pkgver}/build
+ cd build
- cmake .. \
+ cmake ../switchboard-plug-useraccounts-${pkgver} \
-DCMAKE_BUILD_TYPE='Release' \
-DCMAKE_INSTALL_PREFIX='/usr' \
-DCMAKE_INSTALL_LIBDIR='/usr/lib'
@@ -35,7 +33,7 @@ build() {
}
package() {
- cd switchboard-plug-useraccounts-${pkgver}/build
+ cd build
make DESTDIR="${pkgdir}" install
}