summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0276c6da57b7..db1893bed510 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,13 @@
pkgname=switcheroo-control
pkgver=2.5
-pkgrel=1
+pkgrel=2
pkgdesc="D-Bus service to check the availability of dual-GPU"
arch=(i686 x86_64)
url="https://gitlab.freedesktop.org/hadess/switcheroo-control"
license=(GPL3)
depends=(glib2 libgudev python)
makedepends=(git libxslt meson systemd umockdev)
+checkdepends=(dbus-python)
_commit=992977918026e4eec352d38728b2e55f73fd02d2
source=("git+https://gitlab.freedesktop.org/hadess/switcheroo-control.git#commit=$_commit")
sha256sums=('SKIP')
@@ -18,7 +19,11 @@ pkgver() {
build() {
arch-meson $pkgname build
- ninja -C build
+ meson compile -C build
+}
+
+check() {
+ meson test -C build
}
package() {