summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d86927d0030f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: N.Boughton, <nicholasboughton@gmail.com>
+pkgname=swnt
+pkgver=0.7.2
+pkgrel=1
+pkgdesc="Command line GM tools for Stars Without Number"
+arch=('x86_64')
+url="https://github.com/nboughton/swnt"
+license=("MIT")
+depends=("git")
+makedepends=('go')
+optdepends=('hugo: export sectors as hugo sites')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/nboughton/swnt/archive/v${pkgver}.tar.gz")
+sha1sums=('f88eaa46d96b23986453c8bda0d7d77fab22e167')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ go build -v -o swnt
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ install -Dm755 "${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+}