summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 16 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 743b944815ae..c5e1f38258ab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,26 @@
# Maintainer: Thibaut Sautereau (thithib) <thibaut.sautereau@clip-os.org>
pkgname=swtpm
-pkgver=0.1.0
-pkgrel=3
+pkgver=0.2.0
+pkgrel=1
pkgdesc="Libtpms-based TPM emulator with socket, character device, and Linux CUSE interface"
arch=('x86_64')
url="https://github.com/stefanberger/swtpm"
license=('BSD')
-depends=('glib2' 'fuse2' 'libtpms' 'openssl' 'gnutls' 'net-tools' 'tpm-tools' 'expect')
+depends=('glib2' 'fuse2' 'libtpms' 'gnutls' 'net-tools' 'tpm-tools' 'expect')
makedepends=('socat' 'python')
source=("https://codeload.github.com/stefanberger/swtpm/tar.gz/v${pkgver}"
- 'tmpfiles.conf')
-sha256sums=('6b3a3beb12b9bcd286b07961062c2d03a71889be6eb26967fe13d3de62ad7a05'
- 'eb408adb3e40df1cbea7898426fd89c9a2774a970fd3e18a052a530f49c32336')
+ 'tmpfiles.conf'
+ 'https://github.com/stefanberger/swtpm/commit/39673a0139b0ee14a0109aba50a0635592c672c4.patch')
+sha256sums=('977477e341f8b5db0820c8d3cc9946652ef8d7a93403c4dcf88667f9a84ae999'
+ 'eb408adb3e40df1cbea7898426fd89c9a2774a970fd3e18a052a530f49c32336'
+ '3ed1166141e4841e011d00d2c84bf4b691eba79321d399fb5ab3a17d9a324d8e')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ # See https://github.com/stefanberger/swtpm/issues/166
+ patch --strip=1 --input="$srcdir/39673a0139b0ee14a0109aba50a0635592c672c4.patch"
+}
build() {
cd "${pkgname}-${pkgver}"
@@ -37,7 +45,8 @@ check() {
package() {
cd "${pkgname}-${pkgver}"
make DESTDIR="${pkgdir}" install
- install -Dm644 ${srcdir}/tmpfiles.conf ${pkgdir}/usr/lib/tmpfiles.d/swtpm.conf
+ install -Dm644 "$srcdir/tmpfiles.conf" "$pkgdir/usr/lib/tmpfiles.d/swtpm.conf"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
# vim:set ts=2 sw=2 et: