summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8b987c5f2c71
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Jakub Klinkovský <j.l.k@gmx.com>
+
+pkgname=sxlock-git
+_pkgname=sxlock
+pkgver=1.1.7.g639db05
+pkgrel=1
+pkgdesc="Simple screen locker utility for X, fork of sflock. Uses PAM authentication, no suid needed."
+arch=('i686' 'x86_64')
+url="https://github.com/lahwaacz/sxlock"
+license=('MIT')
+depends=('libxext' 'libxrandr' 'pam')
+makedepends=('git')
+source=('git://github.com/lahwaacz/sxlock.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --always | sed 's|^v||;s|-|.|g'
+}
+
+build() {
+ cd "$_pkgname"
+ make
+}
+
+package() {
+ cd "$_pkgname"
+ make DESTDIR="$pkgdir" install
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: