summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 13 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index af20a61ca81d..b9de1de26829 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,20 +7,26 @@
# by setting SYNCTHING_TEST_TIMEOUT_FACTOR
# set the web view provider: either webkit, webengine, auto or none
-_webview_provider=webkit
+_webview_provider=${SYNCTHING_TRAY_WEBVIEW_PROVIDER:-webkit}
+
+# set the JavaScript provider: either script, qml, auto or none
+_js_provider=${SYNCTHING_TRAY_JS_PROVIDER:-qml}
# set to non-empty string to enable KIO plugin to show Syncthing actions in
# Dolphin file browser
-_enable_kio_plugin=1
+_enable_kio_plugin=${SYNCTHING_TRAY_ENABLE_KIO_PLUGIN:-1}
# set to non-empty string to enable Plasmoid for Plasma 5 desktop
-_enable_plasmoid=1
+_enable_plasmoid=${SYNCTHING_TRAY_ENABLE_PLASMOID:-1}
+
+[[ $_enable_kio_plugin == 0 ]] && _enable_kio_plugin=
+[[ $_enable_plasmoid == 0 ]] && _enable_plasmoid=
_reponame=syncthingtray
pkgname=syncthingtray
-pkgver=0.8.2
+pkgver=0.8.3
pkgrel=1
-arch=('i686' 'x86_64')
+arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
pkgdesc='Tray application for Syncthing'
license=('GPL')
depends=('qtutilities' 'qt5-svg' 'openssl' 'desktop-file-utils' 'xdg-utils')
@@ -35,7 +41,7 @@ checkdepends=('cppunit' 'syncthing')
[[ $_enable_plasmoid ]] && makedepends+=('plasma-framework' 'extra-cmake-modules')
url="https://github.com/Martchus/${_reponame}"
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/Martchus/${_reponame}/archive/v${pkgver}.tar.gz")
-sha256sums=('34ebc32c78bfc2c6ebba390e78dafc32e6eddbac7e613ab3b4573f79cb1c01b2')
+sha256sums=('85c7578ce4b2d9c2454cfa4b5b3b5617829d1a77f579e7d33b34bd31542a8b32')
ephemeral_port() {
comm -23 <(seq 49152 65535) <(ss -tan | awk '{print $4}' | cut -d':' -f2 | grep "[0-9]\{1,5\}" | sort | uniq) | shuf | head -n 1
@@ -50,6 +56,7 @@ build() {
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX="/usr" \
-DWEBVIEW_PROVIDER="${_webview_provider}" \
+ -DJS_PROVIDER="${_js_provider}" \
-DSYSTEMD_SUPPORT=ON \
$additional_args
make