summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 6 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b816a20f21c5..fc0549618a89 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
# Contributor: Franco Iacomella <yaco@gnu.org>
pkgname=synfig
-pkgver=1.2.1
-pkgrel=5
+pkgver=1.2.2
+pkgrel=1
pkgdesc="Professional vector animation program (CLI renderer only)"
arch=(x86_64)
url="https://synfig.org"
@@ -15,23 +15,15 @@ depends=('libxml++2.6' 'libsigc++2.0' 'libmagick6' 'ffmpeg' 'fontconfig'
makedepends=('boost')
optdepends=('openexr' 'libsigc++')
source=(
- "https://github.com/$pkgname/$pkgname/releases/download/v$pkgver/ETL-$pkgver.tar.gz"
- "https://github.com/$pkgname/$pkgname/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz"
- 'ETL-1.2.1.patch'
+ "https://github.com/$pkgname/$pkgname/releases/download/v$pkgver/source-ETL-$pkgver.tar.gz"
+ "https://github.com/$pkgname/$pkgname/releases/download/v$pkgver/source-$pkgname-$pkgver.tar.gz"
'ffmpeg-3.0.patch')
sha256sums=(
- '754d88c5ddfdef54f27d1e17f62a902eb9f09fbe7ef9aebded34541b4c1700e6'
- '4d8bada4e99f05ee16b4256fc3f5a551d00a745347944837bbd6fa158b57e457'
- '35e218317050430ebae667d26269903ad1c377407b9a75feb48a9138af131cb0'
+ '0dc19c5a6c9e964054ca3af6dacd6ab0c198d78071cfab2aebac178afe454d8b'
+ '5f5f7b33483041165f9a63fe4d95eb815971c7444569e574206f6964e83cc2ef'
'424b3cc38809038c3b015ce2a6d3a006d73aefe0445d0090fae45e8eb69b2b55')
prepare() {
- # Fix const-invalid method in ETL 1.2.1 using the patch which is included
- # in ETL ≥ 1.3.9. This makes building with GCC possible.
- # (see <https://github.com/synfig/synfig/commit/cb05b072>)
- cd "$srcdir"/ETL-$pkgver
- patch -p1 -i "$srcdir"/ETL-1.2.1.patch
-
# Workaround usage of deprecated ffmpeg constants by manually defining
# them, and other deprecation workarounds
cd "$srcdir"/$pkgname-$pkgver