summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 12 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e7ff334c8822..1d642594ce21 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,27 @@
# Maintainer: "Amhairghin" Oscar Garcia Amor (https://ogarcia.me)
pkgname=sysdweb
-pkgver=1.1.2
+pkgver=1.1.5
pkgrel=1
pkgdesc='Control systemd services through Web or REST API'
arch=('any')
url='https://github.com/ogarcia/sysdweb'
-license=('GPL')
-depends=('python-bottle' 'python-dbus' 'python-pam' 'python-setuptools' 'python-systemd')
-makedepends=('python-setuptools')
+license=('GPL3')
+depends=('python-bottle' 'python-dbus' 'python-pam' 'python-systemd')
+makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel')
backup=("etc/${pkgname}.conf")
-source=("https://github.com/ogarcia/${pkgname}/archive/${pkgver}.tar.gz")
-sha256sums=('b21a159c67e1de312682946bf4fa60c23375e58a91aed134bc8ef5283475f871')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/ogarcia/${pkgname}/archive/${pkgver}.tar.gz")
+sha256sums=('ab0ecea40c93a31ce6bf5f594d7fc6c948ae2debb5482e341bfd5323fc712d2e')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ python -m build --wheel --no-isolation
+}
package() {
cd "${pkgname}-${pkgver}"
- python setup.py install --root="${pkgdir}" --optimize='1'
+ python -m installer --destdir="${pkgdir}" dist/*.whl
# config file
install -D -m644 "${pkgname}.conf" \