summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8908875cc198..2f2299a2f505 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,18 @@
# Contributor: Corey Hinshaw <corey(at)electrickite(dot)org>
pkgname=system76-acpi-dkms
pkgver=1.0.2+4+gb49caa5
-pkgrel=2
+pkgrel=3
pkgdesc="This provides the system76_acpi in-tree driver for systems missing it."
arch=('x86_64')
url="https://github.com/pop-os/system76-acpi-dkms"
license=('GPL')
depends=('dkms')
makedepends=('git')
-conflicts=('linux>=5.16')
_commit=b49caa557e6f902381ca76b6bb8f8a2825ad099b
-source=("git+https://github.com/pop-os/system76-acpi-dkms.git#commit=$_commit")
-sha256sums=('SKIP')
+source=("git+https://github.com/pop-os/system76-acpi-dkms.git#commit=$_commit"
+ "$pkgname.conf")
+sha256sums=('SKIP'
+ '23c2e7c1be0c97ec608f80958d68efbb3bb089ec6429f8ab273be65525df0aaf')
pkgver() {
cd "$srcdir/$pkgname"
@@ -35,7 +36,8 @@ package() {
install -Dm644 -t "$pkgdir/usr/lib/udev/hwdb.d/" lib/udev/hwdb.d/*
# Edit and install dkms configuration
- sed "s/#MODULE_VERSION#/${pkgver//+*/}/" "debian/system76-acpi-dkms.dkms" > "$install_dir/dkms.conf"
+ sed "s/#MODULE_VERSION#/${pkgver//+*/}/" \
+ "$srcdir/system76-acpi-dkms.conf" > "$install_dir/dkms.conf"
# Load the module at boot
install -Dm644 "usr/share/initramfs-tools/modules.d/$pkgname.conf" \