summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD51
1 files changed, 39 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9d0502b5b327..542c2b61278a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,23 +3,37 @@
pkgname=system76-driver
pkgver=17.10.16
-pkgrel=1
+pkgrel=2
pkgdesc="System76 Driver provides drivers, restore, and regression support for System76 computers"
arch=('any')
url="https://launchpad.net/system76-driver"
license=('GPL')
install="${pkgname}.install"
-depends=('python>=3.6' 'python-gobject' 'python-dbus' 'python-evdev' 'dmidecode')
-makepdepends=('python-pyflakes' 'patch')
+depends=(
+ 'python>=3.6'
+ 'python-cffi'
+ 'python-dbus'
+ 'python-evdev'
+ 'python-gobject'
+ 'python-pynacl'
+ 'python-xlib'
+ 'dmidecode')
+makepdepends=(
+ 'python-pyflakes'
+ 'patch')
optdepends=(
- 'pm-utils: For powermanagement features'
- 'gtk3: To launch System76 Driver GUI'
+ 'pm-utils: For power management features'
+ 'gtk3: To launch System76 driver and firmware GUI'
'grub: To apply kernel boot time parameters'
- 'polkit: runnning System76 Driver GUI from application menu'
+ 'polkit: Run System76 Driver GUI from application menu'
'pulseaudio: To apply microphone fix'
'xorg-xbacklight: To use the backlight service')
-source=("https://launchpad.net/~system76-dev/+archive/ubuntu/stable/+files/${pkgname}_${pkgver}.tar.xz"
- 'galu1.patch' 'gtk.patch' 'cli.patch' 'hidpi.patch')
+source=(
+ "https://launchpad.net/~system76-dev/+archive/ubuntu/stable/+files/${pkgname}_${pkgver}.tar.xz"
+ 'galu1.patch'
+ 'gtk.patch'
+ 'cli.patch'
+ 'hidpi.patch')
sha1sums=('c893e0c3123e757a37f2e10fd335fb473b1e2549'
'ea8d53a80a26eb05b367f27996c8ce715aafba1e'
'bf0c37a6226858c768e8ce2c9c3c3801aef14c0e'
@@ -37,23 +51,36 @@ package() {
# Build and install base package
python setup.py install --prefix=/usr --root=${pkgdir} --optimize=1
- # Install daemons and systemd unit files
- # Note: system76-driver* service files shortened to system76*
+ # Install daemons and executables
install -m755 -D system76-daemon ${pkgdir}/usr/lib/${pkgname}/system76-daemon
install -m755 -D system76-backlight-daemon ${pkgdir}/usr/lib/${pkgname}/system76-backlight-daemon
install -m755 -D system76-hidpi-daemon ${pkgdir}/usr/lib/${pkgname}/system76-hidpi-daemon
+ install -m755 -D system76-hidpi-notification ${pkgdir}/usr/lib/${pkgname}/system76-hidpi-notification
+ install -m755 -D system76-firmware-dialog ${pkgdir}/usr/lib/${pkgname}/system76-firmware-dialog
+ install -m755 -D system76-driver-pkexec ${pkgdir}/usr/bin/system76-driver-pkexec
+ install -m755 -D system76-firmware-pkexec ${pkgdir}/usr/bin/system76-firmware-pkexec
+ install -m755 -D system76-firmware ${pkgdir}/usr/bin/system76-firmware
# Install systemd unit files
# Note: system76-driver* service files shortened to system76*
install -m644 -D debian/system76-driver.service ${pkgdir}/usr/lib/systemd/system/system76.service
+ install -m644 -D debian/system76-firmware.service ${pkgdir}/usr/lib/systemd/system/system76-firmware.service
install -m644 -D debian/system76-driver-backlight.service ${pkgdir}/usr/lib/systemd/user/system76-backlight.service
install -m644 -D debian/system76-driver-hidpi.service ${pkgdir}/usr/lib/systemd/user/system76-hidpi.service
- install -m644 -D system76-driver-backlight.desktop ${pkgdir}/usr/share/applications/system76-backlight.desktop
# Install scripts and configuration
- install -m755 -D system76-driver-pkexec ${pkgdir}/usr/bin/system76-driver-pkexec
install -m755 -D system76-nm-restart ${pkgdir}/usr/lib/${pkgname}/system76-nm-restart
install -m644 -D com.system76.pkexec.system76-driver.policy ${pkgdir}/usr/share/polkit-1/actions/com.system76.pkexec.system76-driver.policy
+ install -m644 -D com.system76.pkexec.system76-firmware.policy ${pkgdir}/usr/share/polkit-1/actions/com.system76.pkexec.system76-firmware.policy
+
+ # Install desktop shortcuts
+ install -m644 -D system76-driver-backlight.desktop ${pkgdir}/usr/share/applications/system76-backlight.desktop
+ install -m644 -D system76-driver-hidpi.desktop ${pkgdir}/usr/share/applications/system76-hidpi.desktop
+ install -m644 -D system76-firmware.desktop ${pkgdir}/usr/share/applications/system76-firmware.desktop
+
+ # Install certificates and keys
+ install -m644 -D pinned/ssl/certs/firmware.system76.com.cert ${pkgdir}/usr/share/system76-driver/ssl/certs/firmware.system76.com.cert
+ install -m644 -D pinned/keys/verify ${pkgdir}/usr/share/system76-driver/keys/verify
# Create /var/lib/system76-driver directory for brightness settings saving
install -m755 -d ${pkgdir}/var/lib/${pkgname}