summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6acf567e0dda
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Dwayne Bent <dbb@dbb.io>
+pkgname=systemd-cron
+pkgver=1.5.3
+pkgrel=1
+pkgdesc='systemd units to run cron scripts'
+arch=(any)
+url='https://github.com/systemd-cron/systemd-cron'
+license=('MIT')
+depends=('systemd>=217' 'run-parts' 'python')
+optdepends=('smtp-forwarder: sending emails')
+provides=('cron')
+conflicts=('cron')
+source=("https://github.com/systemd-cron/${pkgname}/archive/v${pkgver}.tar.gz")
+install=${pkgname}.install
+md5sums=('15da1cb2e1171d24927e3241de6f7969')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ ./configure --prefix=/usr --confdir=/etc \
+ --enable-minutely --enable-quarterly --enable-semi_annually --enable-yearly \
+ --enable-persistent --enable-setgid
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ make DESTDIR="${pkgdir}" install
+
+ install -d "${pkgdir}"/etc/cron.{boot,minutely,hourly,daily,weekly,monthly,quarterly,semi-annually,yearly}
+ install -d "${pkgdir}"/var/spool/cron
+}
+