summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2c5845001924
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Konstantin Stepanov <me@kstep.me>
+pkgname=systemd-cron-next
+pkgver=1.0.0.rc1
+pkgrel=1
+pkgdesc="systemd generator to generate timers/services from crontab and anacrontab files"
+url="https://github.com/systemd-cron/systemd-cron-next"
+arch=('any')
+license=('GPL3')
+depends=('systemd')
+makedepends=('rust')
+provides=('cron' 'anacron')
+replaces=('cron' 'anacron')
+source=('https://github.com/systemd-cron/systemd-cron-next/archive/v1.0.0-rc1.zip')
+md5sums=('cdd1fc3ee9a5beb2c829b0444ed173bb')
+
+build() {
+ cd "$srcdir/systemd-cron-next-master"
+ ./configure --prefix="$pkgdir/usr"
+ make build
+}
+
+package() {
+ cd "$srcdir/systemd-cron-next-master"
+ make install
+}