summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3a0994ed7f97..6201918021ea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,7 +12,7 @@ _tag='256.1'
# way or another. So we replace dashes and tildes with the empty string to
# make sure pacman's version comparing does the right thing for rc versions:
pkgver="${_tag/[-~]/}"
-pkgrel=4
+pkgrel=5
arch=('x86_64')
license=('LGPL-2.1-or-later')
url='https://www.github.com/systemd/systemd'
@@ -188,7 +188,7 @@ package_systemd-fml() {
'GPL-2.0-or-later' # udev
'MIT-0' # documentation and config files
)
- depends=("systemd-lib=${pkgver}"
+ depends=("systemd-lib-fml=${pkgver}"
'acl' 'libacl.so' 'bash' 'cryptsetup' 'libcryptsetup.so' 'dbus'
'dbus-units' 'kbd' 'kmod' 'hwdata' 'libcap' 'libcap.so'
'libgcrypt' 'libxcrypt' 'libcrypt.so' 'libidn2' 'lz4' 'pam'
@@ -315,7 +315,7 @@ package_systemd-libs-fml() {
package_systemd-resolvconf-fml() {
pkgdesc='systemd resolvconf replacement (for use with systemd-resolved)'
- depends=("systemd=${pkgver}")
+ depends=("systemd-fml=${pkgver}")
provides=('openresolv' 'resolvconf')
provides+=("systemd-resolvconf=$pkgver")
conflicts=('resolvconf')
@@ -333,7 +333,7 @@ package_systemd-sysvcompat-fml() {
provides=("systemd-sysvcompat=$pkgver")
conflicts=('sysvinit')
conflicts+=('systemd-sysvcompat')
- depends=("systemd=${pkgver}")
+ depends=("systemd-fml=${pkgver}")
install -D -m0644 -t "$pkgdir"/usr/share/man/man8 \
build/man/{halt,poweroff,reboot,shutdown}.8
@@ -347,7 +347,7 @@ package_systemd-sysvcompat-fml() {
package_systemd-tests() {
pkgdesc='systemd tests'
- depends=("systemd=${pkgver}")
+ depends=("systemd-fml=${pkgver}")
install -d -m0755 "$pkgdir"/usr/lib/systemd
mv systemd-tests/tests "$pkgdir"/usr/lib/systemd/tests
@@ -358,7 +358,7 @@ package_systemd-ukify-fml() {
provides=('ukify')
provides+=("systemd-ukify=$pkgver")
conflicts=('systemd-ukify')
- depends=("systemd=${pkgver}" 'binutils' 'python-cryptography' 'python-pefile')
+ depends=("systemd-fml=${pkgver}" 'binutils' 'python-cryptography' 'python-pefile')
optdepends=('python-pillow: Show the size of splash image'
'sbsigntools: Sign the embedded kernel')