summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD303
1 files changed, 189 insertions, 114 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f7ece50600fa..5cbf15eb9e8c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,116 +1,150 @@
# Maintainer: Yurii Kolesnykov <root@yurikoles.com>
-# Credit: Christian Hesse <mail@eworm.de>
-# Credit: Dave Reisner <dreisner@archlinux.org>
-# Credit: Tom Gundersen <teg@jklm.no>
+# Based on testing/systemd by Christian Hesse <mail@eworm.de>
+#
+# PRs are welcome here: https://github.com/yurikoles-aur/systemd-git
+#
pkgbase=systemd-git
-_pkgbase=systemd
-pkgname=('systemd-git' 'systemd-libs-git' 'systemd-resolvconf-git' 'systemd-sysvcompat-git')
-pkgdesc="systemd (git version)"
-pkgver=242.695
+pkgname=('systemd-git'
+ 'systemd-libs-git'
+ 'systemd-resolvconf-git'
+ 'systemd-sysvcompat-git'
+ 'systemd-ukify-git')
+pkgdesc='systemd (git version)'
+pkgver=254.r67973.cde8cc946b
pkgrel=1
arch=('x86_64')
url='https://www.github.com/systemd/systemd'
makedepends=('acl' 'cryptsetup' 'docbook-xsl' 'gperf' 'lz4' 'xz' 'pam' 'libelf'
'intltool' 'iptables' 'kmod' 'libcap' 'libidn2' 'libgcrypt'
- 'libmicrohttpd' 'libxslt' 'util-linux' 'linux-api-headers'
- 'python-lxml' 'quota-tools' 'shadow' 'gnu-efi-libs' 'git'
+ 'libmicrohttpd' 'libxcrypt' 'libxslt' 'util-linux' 'linux-api-headers'
+ 'python-jinja' 'python-lxml' 'quota-tools' 'shadow' 'git'
'meson' 'libseccomp' 'pcre2' 'audit' 'kexec-tools' 'libxkbcommon'
- 'bash-completion')
-options=('!strip')
-source=('git+https://github.com/systemd/systemd'
+ 'bash-completion' 'p11-kit' 'systemd' 'libfido2' 'tpm2-tss' 'rsync'
+ 'bpf' 'libbpf' 'clang' 'llvm' 'curl' 'gnutls' 'python-pyelftools'
+ 'lib32-gcc-libs')
+checkdepends=('python-pefile')
+options=('strip')
+source=("$pkgbase-stable::git+https://github.com/systemd/systemd"
'0001-Use-Arch-Linux-device-access-groups.patch'
+ # mkinitcpio files
'initcpio-hook-udev'
'initcpio-install-systemd'
'initcpio-install-udev'
+ # bootloader files
'arch.conf'
'loader.conf'
- 'splash-arch.bmp'::'https://git.archlinux.org/svntogit/packages.git/plain/trunk/splash-arch.bmp?h=packages/systemd'
+ 'splash-arch.bmp'::'https://gitlab.archlinux.org/archlinux/packaging/packages/systemd/-/raw/main/splash-arch.bmp'
+ # pam configuration
'systemd-user.pam'
+ # pacman / libalpm hooks
'systemd-hook'
- 'systemd-binfmt.hook'
- 'systemd-catalog.hook'
- 'systemd-daemon-reload.hook'
- 'systemd-hwdb.hook'
- 'systemd-sysctl.hook'
- 'systemd-sysusers.hook'
- 'systemd-tmpfiles.hook'
- 'systemd-udev-reload.hook'
- 'systemd-update.hook')
+ '20-systemd-sysusers.hook'
+ '30-systemd-binfmt.hook'
+ '30-systemd-catalog.hook'
+ '30-systemd-daemon-reload.hook'
+ '30-systemd-hwdb.hook'
+ '30-systemd-sysctl.hook'
+ '30-systemd-tmpfiles.hook'
+ '30-systemd-udev-reload.hook'
+ '30-systemd-update.hook')
sha512sums=('SKIP'
- '9348683829190628e25b7b3300fd880c426d555bde330d5fc5150a9a54b3ad9d4d1f2e69ea1dc6d6f086693dacc53c5af30f1fa7ad9b479791fd77bcdafa430e'
- 'f0d933e8c6064ed830dec54049b0a01e27be87203208f6ae982f10fb4eddc7258cb2919d594cbfb9a33e74c3510cfd682f3416ba8e804387ab87d1a217eb4b73'
- '01de24951a05d38eca6b615a7645beb3677ca0e0f87638d133649f6dc14dcd2ea82594a60b793c31b14493a286d1d11a0d25617f54dbfa02be237652c8faa691'
- 'a25b28af2e8c516c3a2eec4e64b8c7f70c21f974af4a955a4a9d45fd3e3ff0d2a98b4419fe425d47152d5acae77d64e69d8d014a7209524b75a81b0edb10bf3a'
+ '3ccf783c28f7a1c857120abac4002ca91ae1f92205dcd5a84aff515d57e706a3f9240d75a0a67cff5085716885e06e62597baa86897f298662ec36a940cf410e'
+ '4a6cd0cf6764863985dc5ad774d7c93b574645a05b3295f989342951d43c71696d069641592e37eeadb6d6f0531576de96b6392224452f15cd9f056fae038f8e'
+ '94a3bf4720d428c2ec4e6c493f78debeb3d3b865ba2bef266f388bffccda8592af81a1fa2cd98f3d60720935e796572fa07256ffafb8d73342214f0ca8ba7acc'
+ 'a8c7e4a2cc9c9987e3c957a1fc3afe8281f2281fffd2e890913dcf00cf704024fb80d86cb75f9314b99b0e03bac275b22de93307bfc226d8be9435497e95b7e6'
'61032d29241b74a0f28446f8cf1be0e8ec46d0847a61dadb2a4f096e8686d5f57fe5c72bcf386003f6520bc4b5856c32d63bf3efe7eb0bc0deefc9f68159e648'
'c416e2121df83067376bcaacb58c05b01990f4614ad9de657d74b6da3efa441af251d13bf21e3f0f71ddcb4c9ea658b81da3d915667dc5c309c87ec32a1cb5a5'
'5a1d78b5170da5abe3d18fdf9f2c3a4d78f15ba7d1ee9ec2708c4c9c2e28973469bc19386f70b3cf32ffafbe4fcc4303e5ebbd6d5187a1df3314ae0965b25e75'
'b90c99d768dc2a4f020ba854edf45ccf1b86a09d2f66e475de21fe589ff7e32c33ef4aa0876d7f1864491488fd7edb2682fc0d68e83a6d4890a0778dc2d6fe19'
- '6b82386fc20619eefa911cd9cdac8efbd0c7137bba4955e8ae75a0ea378d19dbfccc1f7bde6684f03e5f2badefa4abf20623153d88a170d14499167319586db7'
- '5a6b6beef8c31c79018884d948de840f4d3dfb07d9a87081ebf65e2b8fe595bc8c96dbd7742920ccf948c233213ed0026abc913650cefd77ad90c6f8c89bddb8'
- '4cff2ebd962e26e2f516d8b4ac45c839dbfa54dd0588b423c224a328b9f7c62306ca7b2f6cb55240c564caf9972d5bcd2e0efaf2de49d64729aeb3bc1560c9eb'
- '872de70325e9798f0b5a77e991c85bd2ab6de24d9b9ba4e35002d2dd5df15f8b30739a0042a624776177ffc14a838cde7ee98622016ed41df3efda9a659730b2'
- '471342b8d0e05533908cda5d6a906050a51e3181beda1239e91d717029ee40a9eaed714996a445417d87c4e31b7f8522a665de176077fe0536d538369594996d'
- 'da783e3bfc6469b92dee4064a13e2b427520d3d96b57c95a4e07aaca3e844d95210a8b16122b022080f5452d65096f274dd1c1467725bbdb2e40ef304b78774a'
- '08a590d08043a21f30f04252164b94df972b1ff1022a0469d6aef713e14484a3a037cce290a2a582851e6fac3e64add69d6cc8fc130bbeeaea08626ebf3e1763'
- '577e33a1c50b4b41157a67f64162b035dd0c4a541e19cee55a100048bdb50cb2c82852741b1372989a0fe4c4782ba477522747fcc81d72aed99b3db512a86447'
- 'e4a9d7607fe93daf1d45270971c8d8455c4bfc2c0bea8bcad05aeb89847edee23cd1a41073a72042622acf417018fe254f5bfc137604fe2c71292680bf67a1c2'
- '209b01b044877cc986757fa4009a92ea98f480306c2530075d153203c3cd2b3afccab6aacc1453dee8857991e04270572f1700310705d7a0f4d5bed27fab8c67')
-prepare() {
- cd "$_pkgbase"
+ '5c4119bf1d84b22986dc8d0c4c2de26500b824c21dfac69f22e36809e2673f0652447cc8c9f77190ad098896f4a5e1d03fa33676fe962de631bbfa44513a8860'
+ '299dcc7094ce53474521356647bdd2fb069731c08d14a872a425412fcd72da840727a23664b12d95465bf313e8e8297da31259508d1c62cc2dcea596160e21c5'
+ '0d6bc3d928cfafe4e4e0bc04dbb95c5d2b078573e4f9e0576e7f53a8fab08a7077202f575d74a3960248c4904b5f7f0661bf17dbe163c524ab51dd30e3cb80f7'
+ '2b50b25e8680878f7974fa9d519df7e141ca11c4bfe84a92a5d01bb193f034b1726ea05b3c0030bad1fbda8dbb78bf1dc7b73859053581b55ba813c39b27d9dc'
+ '63e55b3acd14bc54320b6f2310b43398651ad4e262d4f4a0135e05d34a993e56ed673cc46e57f15b418371df5c4cef6f54486db96325e4abb1d33fb1a3946254'
+ 'a1661ab946c6cd7d3c6251a2a9fd68afe231db58ce33c92c42594aedb5629be8f299ba08a34713327b373a3badd1554a150343d8d3e5dfb102999c281bd49154'
+ '9426829605bbb9e65002437e02ed54e35c20fdf94706770a3dc1049da634147906d6b98bf7f5e7516c84068396a12c6feaf72f92b51bdf19715e0f64620319de'
+ 'da7a97d5d3701c70dd5388b0440da39006ee4991ce174777931fea2aa8c90846a622b2b911f02ae4d5fffb92680d9a7e211c308f0f99c04896278e2ee0d9a4dc'
+ 'a50d202a9c2e91a4450b45c227b295e1840cc99a5e545715d69c8af789ea3dd95a03a30f050d52855cabdc9183d4688c1b534eaa755ebe93616f9d192a855ee3'
+ '825b9dd0167c072ba62cabe0677e7cd20f2b4b850328022540f122689d8b25315005fa98ce867cf6e7460b2b26df16b88bb3b5c9ebf721746dce4e2271af7b97')
- # Replace cdrom/dialout/tape groups with optical/uucp/storage
- patch -Np1 -i ../0001-Use-Arch-Linux-device-access-groups.patch
+pkgver() {
+ cd "$pkgbase-stable"
+ local _major=`grep -m1 version meson.build | cut -d\' -f2`
+ printf "%s.r%s.%s" "${_major}" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-pkgver() {
- cd "$_pkgbase"
+prepare() {
+ cd "$pkgbase-stable"
- local _version _count
- _version="$(git describe --abbrev=0 --tags)"
- _count="$(git rev-list --count ${_version}..)"
- printf '%s.%s' "${_version#v}" "${_count}"
+ # Replace cdrom/dialout/tape groups with optical/uucp/storage
+ patch -Np1 -i ../0001-Use-Arch-Linux-device-access-groups.patch
}
build() {
local _timeservers=({0..3}.arch.pool.ntp.org)
local _nameservers=(
- # We use these public name services, ordered by their
- # privacy policy (hopefully):
+ # We use these public name services, ordered by their privacy policy (hopefully):
# * Cloudflare (https://1.1.1.1/)
- # * Quad9 without filtering (https://www.quad9.net/)
+ # * Quad9 (https://www.quad9.net/)
# * Google (https://developers.google.com/speed/public-dns/)
- 1.1.1.1
- 9.9.9.10
- 8.8.8.8
- 2606:4700:4700::1111
- 2620:fe::10
- 2001:4860:4860::8888
+ '1.1.1.1#cloudflare-dns.com'
+ '9.9.9.9#dns.quad9.net'
+ '8.8.8.8#dns.google'
+ '2606:4700:4700::1111#cloudflare-dns.com'
+ '2620:fe::9#dns.quad9.net'
+ '2001:4860:4860::8888#dns.google'
)
local _meson_options=(
- -Dversion-tag="${pkgver}-${pkgrel}-git"
-
- -Dgnu-efi=true
+ # internal version comparison is incompatible with pacman:
+ # 249~rc1 < 249 < 249.1 < 249rc
+ -Dversion-tag="${pkgver}-${pkgrel}-arch"
+ -Dshared-lib-tag="${pkgver}-${pkgrel}"
+ -Dmode=release
+
+ -Dapparmor=false
+ -Dbootloader=true
+ -Dbpf-framework=true
-Dima=false
-Dlibidn2=true
-Dlz4=true
-
+ -Dman=true
+ -Dnscd=false
+ -Dpasswdqc=false
+ -Dpwquality=false
+ -Dqrencode=false
+ -Dselinux=false
+ -Dxenctrl=false
+
+ # We disable DNSSEC by default, it still causes trouble:
+ # https://github.com/systemd/systemd/issues/10579
+
-Ddbuspolicydir=/usr/share/dbus-1/system.d
- -Ddefault-hierarchy=hybrid
- -Ddefault-locale=C
+ -Ddefault-dnssec=no
+ -Ddefault-hierarchy=unified
-Ddefault-kill-user-processes=false
+ -Ddefault-locale='C.UTF-8'
+ -Dlocalegen-path=/usr/bin/locale-gen
+ -Ddns-over-tls=openssl
-Dfallback-hostname='archlinux'
+ -Dnologin-path=/usr/bin/nologin
-Dntp-servers="${_timeservers[*]}"
-Ddns-servers="${_nameservers[*]}"
-Drpmmacrosdir=no
-Dsysvinit-path=
-Dsysvrcnd-path=
+
+ -Dsbat-distro='arch'
+ -Dsbat-distro-summary='Arch Linux AUR'
+ -Dsbat-distro-pkgname="${pkgname}"
+ -Dsbat-distro-version="${pkgver}"
+ -Dsbat-distro-url="https://aur.archlinux.org/pkgbase/${pkgname}"
)
-
- arch-meson "$_pkgbase" build "${_meson_options[@]}"
- ninja -C build
+ arch-meson "$pkgbase-stable" build "${_meson_options[@]}"
+
+ meson compile -C build
}
check() {
@@ -118,62 +152,80 @@ check() {
}
package_systemd-git() {
- pkgdesc="system and service manager (git version)"
+ pkgdesc='system and service manager'
+ pkgdesc+=' (git version)'
license=('GPL2' 'LGPL2.1')
- depends=('acl' 'bash' 'cryptsetup' 'dbus' 'iptables' 'kbd' 'kmod' 'hwids' 'libcap'
- 'libgcrypt' 'systemd-libs' 'libidn2' 'libidn2.so' 'lz4' 'pam' 'libelf'
- 'libseccomp' 'util-linux' 'xz' 'pcre2' 'audit')
- provides=("${_pkgbase}=$pkgver" 'nss-myhostname' "systemd-tools=$pkgver" "udev=$pkgver")
- replaces=('nss-myhostname' 'systemd-tools' 'udev')
- conflicts=("${_pkgbase}" 'nss-myhostname' 'systemd-tools' 'udev')
- optdepends=('libmicrohttpd: remote journald capabilities'
+ depends=('acl' 'libacl.so' 'bash' 'cryptsetup' 'libcryptsetup.so' 'dbus'
+ 'iptables' 'kbd' 'kmod' 'libkmod.so' 'hwdata' 'libcap' 'libcap.so'
+ 'libgcrypt' 'libxcrypt' 'libcrypt.so' "systemd-libs-git=$pkgver" 'libidn2' 'lz4' 'pam'
+ 'libelf' 'libseccomp' 'libseccomp.so' 'util-linux' 'libblkid.so'
+ 'libmount.so' 'xz' 'pcre2' 'audit' 'libaudit.so'
+ 'openssl' 'libcrypto.so' 'libssl.so')
+ provides=('nss-myhostname' "systemd-tools=$pkgver" "udev=$pkgver")
+ provides+=("systemd=$pkgver")
+ conflicts=('nss-myhostname' 'systemd-tools' 'udev')
+ conflicts+=('systemd')
+ optdepends=('libmicrohttpd: systemd-journal-gatewayd and systemd-journal-remote'
'quota-tools: kernel-level quota management'
- 'systemd-sysvcompat-git: symlink package to provide sysvinit binaries'
+ 'systemd-sysvcompat: symlink package to provide sysvinit binaries'
+ "systemd-ukify-git=$pkgver: combine kernel and initrd into a signed Unified Kernel Image"
'polkit: allow administration as unprivileged user'
- 'curl: machinectl pull-tar and pull-raw')
+ 'python: Unified Kernel Image with ukify'
+ 'curl: systemd-journal-upload, machinectl pull-tar and pull-raw'
+ 'gnutls: systemd-journal-gatewayd and systemd-journal-remote'
+ 'libbpf: support BPF programs'
+ 'libfido2: unlocking LUKS2 volumes with FIDO2 token'
+ 'libp11-kit: support PKCS#11'
+ 'tpm2-tss: unlocking LUKS2 volumes with TPM2')
backup=(etc/pam.d/systemd-user
etc/systemd/coredump.conf
+ etc/systemd/homed.conf
etc/systemd/journald.conf
etc/systemd/journal-remote.conf
etc/systemd/journal-upload.conf
etc/systemd/logind.conf
etc/systemd/networkd.conf
+ etc/systemd/oomd.conf
+ etc/systemd/pstore.conf
etc/systemd/resolved.conf
etc/systemd/sleep.conf
etc/systemd/system.conf
etc/systemd/timesyncd.conf
etc/systemd/user.conf
+ etc/udev/iocost.conf
etc/udev/udev.conf)
install=systemd.install
- DESTDIR="$pkgdir" meson install -C build
-
- # don't write units to /etc by default. some of these will be re-enabled on
- # post_install.
- rm -rfv "$pkgdir"/etc/systemd/system/*
+ meson install -C build --destdir "$pkgdir"
# we'll create this on installation
rmdir "$pkgdir"/var/log/journal/remote
# runtime libraries shipped with systemd-libs
- install -d -m0755 systemd-libs
- mv "$pkgdir"/usr/lib/lib{nss,systemd,udev}*.so* systemd-libs
+ install -d -m0755 systemd-libs/lib/
+ mv "$pkgdir"/usr/lib/lib{nss,systemd,udev}*.so* systemd-libs/lib/
+ mv "$pkgdir"/usr/lib/pkgconfig systemd-libs/lib/pkgconfig
+ mv "$pkgdir"/usr/include systemd-libs/include
+ mv "$pkgdir"/usr/share/man/man3 systemd-libs/man3
+
+ # ukify shipped in separate package
+ install -d -m0755 systemd-ukify/{systemd,man1}
+ mv "$pkgdir"/usr/lib/systemd/ukify systemd-ukify/systemd/
+ mv "$pkgdir"/usr/share/man/man1/ukify.1 systemd-ukify/man1/
# manpages shipped with systemd-sysvcompat
- rm -f "$pkgdir"/usr/share/man/man8/{halt,poweroff,reboot,runlevel,shutdown,telinit}.8
+ rm "$pkgdir"/usr/share/man/man8/{halt,poweroff,reboot,shutdown}.8
# executable (symlinks) shipped with systemd-sysvcompat
- rm -f "$pkgdir"/usr/bin/{halt,init,poweroff,reboot,runlevel,shutdown,telinit}
+ rm "$pkgdir"/usr/bin/{halt,init,poweroff,reboot,shutdown}
# files shipped with systemd-resolvconf
- rm -f "$pkgdir"/usr/{bin/resolvconf,share/man/man1/resolvconf.1}
+ rm "$pkgdir"/usr/{bin/resolvconf,share/man/man1/resolvconf.1}
# avoid a potential conflict with [core]/filesystem
- rm -f "$pkgdir"/usr/share/factory/etc/nsswitch.conf
- sed -i '/^C \/etc\/nsswitch\.conf/d' "$pkgdir"/usr/lib/tmpfiles.d/etc.conf
-
- # add back tmpfiles.d/legacy.conf, normally omitted without sysv-compat
- install -m0644 $_pkgbase/tmpfiles.d/legacy.conf "$pkgdir"/usr/lib/tmpfiles.d
+ rm "$pkgdir"/usr/share/factory/etc/{issue,nsswitch.conf}
+ sed -i -e '/^C \/etc\/nsswitch\.conf/d' \
+ -e '/^C \/etc\/issue/d' "$pkgdir"/usr/lib/tmpfiles.d/etc.conf
# ship default policy to leave services disabled
echo 'disable *' >"$pkgdir"/usr/lib/systemd/system-preset/99-default.preset
@@ -183,11 +235,10 @@ package_systemd-git() {
install -D -m0644 initcpio-install-udev "$pkgdir"/usr/lib/initcpio/install/udev
install -D -m0644 initcpio-hook-udev "$pkgdir"/usr/lib/initcpio/hooks/udev
- # ensure proper permissions for /var/log/journal
- # The permissions are stored with named group by tar, so this works with
- # users and groups populated by systemd-sysusers. This is only to prevent a
- # warning from pacman as permissions are set by systemd-tmpfiles anyway.
- install -d -o root -g systemd-journal -m 2755 "$pkgdir"/var/log/journal
+ # The group 'systemd-journal' is allocated dynamically and may have varying
+ # gid on different systems. Let's install with gid 0 (root), systemd-tmpfiles
+ # will fix the permissions for us. (see /usr/lib/tmpfiles.d/systemd.conf)
+ install -d -o root -g root -m 2755 "$pkgdir"/var/log/journal
# match directory owner/group and mode from [extra]/polkit
install -d -o root -g 102 -m 0750 "$pkgdir"/usr/share/polkit-1/rules.d
@@ -206,23 +257,30 @@ package_systemd-git() {
}
package_systemd-libs-git() {
- pkgdesc='systemd client libraries (git version)'
- depends=('glibc' 'libcap' 'libgcrypt' 'lz4' 'xz')
+ pkgdesc='systemd client libraries'
+ pkgdesc+=' (git version)'
+ depends=('glibc' 'gcc-libs' 'libcap' 'libgcrypt' 'lz4' 'xz' 'zstd')
license=('LGPL2.1')
- provides=('systemd-libs' 'libsystemd' 'libsystemd.so' 'libudev.so')
- conflicts=('systemd-libs' 'libsystemd')
- replaces=('libsystemd')
-
- install -d -m0755 "$pkgdir"/usr
- mv systemd-libs "$pkgdir"/usr/lib
+ provides=('libsystemd' 'libsystemd.so' 'libudev.so')
+ provides+=("systemd-libs=$pkgver")
+ conflicts=('libsystemd')
+ conflicts+=('systemd-libs')
+
+ install -d -m0755 "$pkgdir"/usr/share/man
+ mv systemd-libs/lib "$pkgdir"/usr/lib
+ mv systemd-libs/include "$pkgdir"/usr/include
+ mv systemd-libs/man3 "$pkgdir"/usr/share/man/man3
}
package_systemd-resolvconf-git() {
- pkgdesc='systemd resolvconf replacement (for use with systemd-resolved, git version)'
+ pkgdesc='systemd resolvconf replacement (for use with systemd-resolved)'
+ pkgdesc+=' (git version)'
license=('LGPL2.1')
- depends=("${pkgbase}")
- provides=('systemd-resolvconf' 'openresolv' 'resolvconf')
- conflicts=('systemd-resolvconf' 'openresolv')
+ depends=("systemd-git=$pkgver")
+ provides=('openresolv' 'resolvconf')
+ provides+=("systemd-resolvconf=$pkgver")
+ conflicts=('openresolv')
+ conflicts+=('systemd-resolvconf')
install -d -m0755 "$pkgdir"/usr/bin
ln -s resolvectl "$pkgdir"/usr/bin/resolvconf
@@ -231,20 +289,37 @@ package_systemd-resolvconf-git() {
ln -s resolvectl.1.gz "$pkgdir"/usr/share/man/man1/resolvconf.1.gz
}
-
package_systemd-sysvcompat-git() {
- pkgdesc='sysvinit compat for systemd (git version)'
+ pkgdesc='sysvinit compat for systemd'
+ pkgdesc+=' (git version)'
license=('GPL2')
- depends=("${pkgbase}")
- provides=('systemd-sysvcompat')
- conflicts=('systemd-sysvcompat' 'sysvinit')
+ conflicts=('sysvinit')
+ conflicts+=('systemd-sysvcompat')
+ depends=("systemd-git=$pkgver")
+ provides=("systemd-sysvcompat=$pkgver")
- # install -D -m0644 -t "$pkgdir"/usr/share/man/man8 \
- # build/man/{telinit,halt,reboot,poweroff,runlevel,shutdown}.8
+ install -D -m0644 -t "$pkgdir"/usr/share/man/man8 \
+ build/man/{halt,poweroff,reboot,shutdown}.8
install -d -m0755 "$pkgdir"/usr/bin
ln -s ../lib/systemd/systemd "$pkgdir"/usr/bin/init
- for tool in runlevel reboot shutdown poweroff halt telinit; do
+ for tool in halt poweroff reboot shutdown; do
ln -s systemctl "$pkgdir"/usr/bin/$tool
done
}
+
+package_systemd-ukify-git() {
+ pkgdesc='Combine kernel and initrd into a signed Unified Kernel Image'
+ pkgdesc+=' (git version)'
+ license=('GPL2')
+ conflicts=('systemd-ukify')
+ provides=('ukify')
+ provides+=("systemd-ukify=$pkgver")
+ depends=('binutils' 'python-cryptography' 'python-pefile' "systemd-git=$pkgver")
+ optdepends=('python-pillow: Show the size of splash image'
+ 'sbsigntools: Sign the embedded kernel')
+
+ install -d -m0755 "$pkgdir"/usr/{lib,share/man}
+ mv systemd-ukify/systemd "$pkgdir"/usr/lib/systemd
+ mv systemd-ukify/man1 "$pkgdir"/usr/share/man/man1
+}