summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 8 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7c976d976702..bd2835fea612 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgbase=systemd-git
_pkgbase=systemd
pkgname=('systemd-git' 'systemd-libs-git' 'systemd-resolvconf-git' 'systemd-sysvcompat-git')
pkgdesc="systemd (git version)"
-pkgver=241.318
+pkgver=241.338
pkgrel=1
arch=('x86_64')
url='https://www.github.com/systemd/systemd'
@@ -91,6 +91,8 @@ build() {
)
local _meson_options=(
+ -Dversion-tag="${pkgver}-${pkgrel}-git"
+
-Dgnu-efi=true
-Dima=false
-Dlibidn2=true
@@ -124,7 +126,7 @@ package_systemd-git() {
'libgcrypt' 'systemd-libs' 'libidn2' 'libidn2.so' 'lz4' 'pam' 'libelf'
'libseccomp' 'util-linux' 'xz' 'pcre2' 'audit')
provides=("${_pkgbase}=$pkgver" 'nss-myhostname' "systemd-tools=$pkgver" "udev=$pkgver")
- replaces=("${_pkgbase}" 'nss-myhostname' 'systemd-tools' 'udev')
+ replaces=('nss-myhostname' 'systemd-tools' 'udev')
conflicts=("${_pkgbase}" 'nss-myhostname' 'systemd-tools' 'udev')
optdepends=('libmicrohttpd: remote journald capabilities'
'quota-tools: kernel-level quota management'
@@ -137,9 +139,11 @@ package_systemd-git() {
etc/systemd/journal-remote.conf
etc/systemd/journal-upload.conf
etc/systemd/logind.conf
+ etc/systemd/networkd.conf
+ etc/systemd/resolved.conf
+ etc/systemd/sleep.conf
etc/systemd/system.conf
etc/systemd/timesyncd.conf
- etc/systemd/resolved.conf
etc/systemd/user.conf
etc/udev/udev.conf)
install=systemd.install
@@ -209,7 +213,7 @@ package_systemd-libs-git() {
license=('LGPL2.1')
provides=('systemd-libs' 'libsystemd' 'libsystemd.so' 'libudev.so')
conflicts=('systemd-libs' 'libsystemd')
- replaces=('systemd-libs' 'libsystemd')
+ replaces=('libsystemd')
install -d -m0755 "$pkgdir"/usr
mv systemd-libs "$pkgdir"/usr/lib
@@ -221,7 +225,6 @@ package_systemd-resolvconf-git() {
depends=('systemd-git')
provides=('systemd-resolvconf' 'openresolv' 'resolvconf')
conflicts=('systemd-resolvconf' 'openresolv')
- replaces=('systemd-resolvconf')
install -d -m0755 "$pkgdir"/usr/bin
ln -s resolvectl "$pkgdir"/usr/bin/resolvconf
@@ -237,7 +240,6 @@ package_systemd-sysvcompat-git() {
depends=('systemd-git')
provides=('systemd-sysvcompat')
conflicts=('systemd-sysvcompat' 'sysvinit')
- replaces=('systemd-sysvcompat')
install -D -m0644 -t "$pkgdir"/usr/share/man/man8 \
build/man/{telinit,halt,reboot,poweroff,runlevel,shutdown}.8