summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6293aebcad9c..464ef87f7dad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ _pkgbase=systemd
pkgbase=$_pkgbase-git
pkgname=('systemd-git' 'systemd-libs-git' 'systemd-resolvconf-git' 'systemd-sysvcompat-git')
pkgdesc='systemd (git version)'
-pkgver=251.r58942.91375fb9cf
+pkgver=251.r59852.cb19517490
pkgrel=1
arch=('x86_64')
url='https://www.github.com/systemd/systemd'
@@ -85,6 +85,10 @@ build() {
local _meson_options=(
-Dmode=release
+ # https://bugs.archlinux.org/task/75852
+ --buildtype debugoptimized
+ -D b_ndebug=true
+
-Dgnu-efi=true
-Dima=false
-Dlibidn2=true
@@ -164,7 +168,7 @@ package_systemd-git() {
etc/udev/udev.conf)
install=systemd.install
- DESTDIR="$pkgdir" meson install -C build
+ meson install -C build --destdir "$pkgdir"
# we'll create this on installation
rmdir "$pkgdir"/var/log/journal/remote