summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD290
1 files changed, 163 insertions, 127 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4a8bab314e6d..3fe2894738ba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,4 @@
# Maintainer: Christian Hesse <mail@eworm.de>
-# Maintainer: Dave Reisner <dreisner@archlinux.org>
-# Maintainer: Tom Gundersen <teg@jklm.no>
# SELinux Maintainer: Nicolas Iooss (nicolas <dot> iooss <at> m4x <dot> org)
# SELinux Contributor: Timothée Ravier <tim@siosm.fr>
# SELinux Contributor: Nicky726 <Nicky726@gmail.com>
@@ -9,48 +7,55 @@
# If you want to help keep it up to date, please open a Pull Request there.
pkgbase=systemd-selinux
-pkgname=('systemd-selinux' 'systemd-libs-selinux' 'systemd-resolvconf-selinux' 'systemd-sysvcompat-selinux')
-# Can be from either systemd or systemd-stable
-_commit='ef677436aa203c24816021dd698b57f219f0ff64'
-pkgver=243.78
-pkgrel=1
-arch=('x86_64')
+pkgname=('systemd-selinux'
+ 'systemd-libs-selinux'
+ 'systemd-resolvconf-selinux'
+ 'systemd-sysvcompat-selinux'
+ 'systemd-ukify-selinux')
+_tag='4003dd6754e3446691402d3cc389fbfd4faccc90' # git rev-parse v${_tag_name}
+_tag_name=255.4
+# Upstream versioning is incompatible with pacman's version comparisons so we
+# replace tildes with the empty string to make sure pacman's version comparing
+# does the right thing for rc versions:
+# ➜ vercmp 255~rc1 255
+# 1
+# ➜ vercmp 255rc1 255
+# -1
+pkgver="${_tag_name/~/}"
+pkgrel=2
+arch=('x86_64' 'aarch64')
+license=('LGPL-2.1-or-later')
url='https://www.github.com/systemd/systemd'
groups=('selinux')
makedepends=('acl' 'cryptsetup' 'docbook-xsl' 'gperf' 'lz4' 'xz' 'pam-selinux' 'libelf'
'intltool' 'iptables' 'kmod' 'libcap' 'libidn2' 'libgcrypt'
- 'libmicrohttpd' 'libxslt' 'util-linux' 'linux-api-headers'
- 'python-lxml' 'quota-tools' 'shadow-selinux' 'gnu-efi-libs' 'git'
+ 'libmicrohttpd' 'libxcrypt' 'libxslt' 'util-linux' 'linux-api-headers'
+ 'python-jinja' 'python-lxml' 'quota-tools' 'shadow-selinux' 'git'
'meson' 'libseccomp' 'pcre2' 'audit' 'kexec-tools' 'libxkbcommon'
- 'bash-completion' 'libselinux')
-options=('strip')
+ 'bash-completion' 'p11-kit' 'systemd' 'libfido2' 'tpm2-tss' 'rsync'
+ 'bpf' 'libbpf' 'clang' 'llvm' 'curl' 'gnutls' 'python-pyelftools'
+ 'libpwquality' 'qrencode' 'lib32-gcc-libs' 'python-pefile' 'libselinux')
+conflicts=("mkinitcpio<38-1")
validpgpkeys=('63CDA1E5D3FC22B998D20DD6327F26951A015CC4' # Lennart Poettering <lennart@poettering.net>
+ 'A9EA9081724FFAE0484C35A1A81CEA22BC8C7E2E' # Luca Boccassi <luca.boccassi@gmail.com>
+ '9A774DB5DB996C154EBBFBFDA0099A18E29326E1' # Yu Watanabe <watanabe.yu+github@gmail.com>
'5C251B5FC54EB2F80F407AAAC54CA336CFEB557E') # Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>
-# Retrieve the splash-arch.bmp image from systemd package sources, as this
-# file is too big to fit in the AUR.
-#
-# systemd 238.0-2 removed the ".git" from the Github URLs
-# (cf. https://git.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/systemd&id=fa248b709cd106bf65b42f3e93e68decc811e163 )
-# When updating, if makepkg reports "systemd-stable is not a clone of https://github.com/systemd/systemd-stable",
-# you need to update the remotes of the git repositories, for example with the following commands:
-# git -C systemd-stable remote set-url origin https://github.com/systemd/systemd-stable
-# git -C systemd remote set-url origin https://github.com/systemd/systemd
-source=(# fragment is latest tag for source verification, final merge in prepare()
- "git+https://github.com/systemd/systemd-stable#tag=v${pkgver%.*}?signed"
- "git+https://github.com/systemd/systemd#tag=v${pkgver%.*}?signed"
+source=("git+https://github.com/systemd/systemd-stable#tag=${_tag}?signed"
+ "git+https://github.com/systemd/systemd#tag=v${_tag_name%.*}?signed"
'0001-Use-Arch-Linux-device-access-groups.patch'
- 'initcpio-hook-udev'
- 'initcpio-install-systemd'
- 'initcpio-install-udev'
+ # bootloader files
'arch.conf'
'loader.conf'
- 'splash-arch.bmp::https://projects.archlinux.org/svntogit/packages.git/plain/trunk/splash-arch.bmp?h=packages/systemd&id=e43ddb71a5b1ab56e898347a63e54c5d5d07728a'
+ 'splash-arch.bmp::https://raw.githubusercontent.com/archlinux/svntogit-packages/391c1f5d4a18d08be809caa08c769ef9cded28db/trunk/splash-arch.bmp'
+ # pam configuration
'systemd-user.pam'
+ # pacman / libalpm hooks
'systemd-hook'
'20-systemd-sysusers.hook'
'30-systemd-binfmt.hook'
'30-systemd-catalog.hook'
- '30-systemd-daemon-reload.hook'
+ '30-systemd-daemon-reload-system.hook'
+ '30-systemd-daemon-reload-user.hook'
'30-systemd-hwdb.hook'
'30-systemd-sysctl.hook'
'30-systemd-tmpfiles.hook'
@@ -58,24 +63,22 @@ source=(# fragment is latest tag for source verification, final merge in prepare
'30-systemd-update.hook')
sha512sums=('SKIP'
'SKIP'
- '9348683829190628e25b7b3300fd880c426d555bde330d5fc5150a9a54b3ad9d4d1f2e69ea1dc6d6f086693dacc53c5af30f1fa7ad9b479791fd77bcdafa430e'
- 'f0d933e8c6064ed830dec54049b0a01e27be87203208f6ae982f10fb4eddc7258cb2919d594cbfb9a33e74c3510cfd682f3416ba8e804387ab87d1a217eb4b73'
- '01de24951a05d38eca6b615a7645beb3677ca0e0f87638d133649f6dc14dcd2ea82594a60b793c31b14493a286d1d11a0d25617f54dbfa02be237652c8faa691'
- 'a25b28af2e8c516c3a2eec4e64b8c7f70c21f974af4a955a4a9d45fd3e3ff0d2a98b4419fe425d47152d5acae77d64e69d8d014a7209524b75a81b0edb10bf3a'
+ '3ccf783c28f7a1c857120abac4002ca91ae1f92205dcd5a84aff515d57e706a3f9240d75a0a67cff5085716885e06e62597baa86897f298662ec36a940cf410e'
'61032d29241b74a0f28446f8cf1be0e8ec46d0847a61dadb2a4f096e8686d5f57fe5c72bcf386003f6520bc4b5856c32d63bf3efe7eb0bc0deefc9f68159e648'
'c416e2121df83067376bcaacb58c05b01990f4614ad9de657d74b6da3efa441af251d13bf21e3f0f71ddcb4c9ea658b81da3d915667dc5c309c87ec32a1cb5a5'
'5a1d78b5170da5abe3d18fdf9f2c3a4d78f15ba7d1ee9ec2708c4c9c2e28973469bc19386f70b3cf32ffafbe4fcc4303e5ebbd6d5187a1df3314ae0965b25e75'
'b90c99d768dc2a4f020ba854edf45ccf1b86a09d2f66e475de21fe589ff7e32c33ef4aa0876d7f1864491488fd7edb2682fc0d68e83a6d4890a0778dc2d6fe19'
- '869dab2b1837c964add4019bb402e24e52dbb7f009850ca69fcc5deddd923eeb98eb8ee38601f6e31531f30322472fe7df09af84df27f0467708406c55885323'
- '08a590d08043a21f30f04252164b94df972b1ff1022a0469d6aef713e14484a3a037cce290a2a582851e6fac3e64add69d6cc8fc130bbeeaea08626ebf3e1763'
- '5a6b6beef8c31c79018884d948de840f4d3dfb07d9a87081ebf65e2b8fe595bc8c96dbd7742920ccf948c233213ed0026abc913650cefd77ad90c6f8c89bddb8'
- '4cff2ebd962e26e2f516d8b4ac45c839dbfa54dd0588b423c224a328b9f7c62306ca7b2f6cb55240c564caf9972d5bcd2e0efaf2de49d64729aeb3bc1560c9eb'
- '872de70325e9798f0b5a77e991c85bd2ab6de24d9b9ba4e35002d2dd5df15f8b30739a0042a624776177ffc14a838cde7ee98622016ed41df3efda9a659730b2'
- '471342b8d0e05533908cda5d6a906050a51e3181beda1239e91d717029ee40a9eaed714996a445417d87c4e31b7f8522a665de176077fe0536d538369594996d'
- 'da783e3bfc6469b92dee4064a13e2b427520d3d96b57c95a4e07aaca3e844d95210a8b16122b022080f5452d65096f274dd1c1467725bbdb2e40ef304b78774a'
- '577e33a1c50b4b41157a67f64162b035dd0c4a541e19cee55a100048bdb50cb2c82852741b1372989a0fe4c4782ba477522747fcc81d72aed99b3db512a86447'
- 'e4a9d7607fe93daf1d45270971c8d8455c4bfc2c0bea8bcad05aeb89847edee23cd1a41073a72042622acf417018fe254f5bfc137604fe2c71292680bf67a1c2'
- '209b01b044877cc986757fa4009a92ea98f480306c2530075d153203c3cd2b3afccab6aacc1453dee8857991e04270572f1700310705d7a0f4d5bed27fab8c67')
+ '3cb8f88c1bffc753d0c540be5d25a0fdb9224478cca64743b5663340f2f26b197775286e6e680228db54c614dcd11da1135e625674a622127681662bec4fa886'
+ '299dcc7094ce53474521356647bdd2fb069731c08d14a872a425412fcd72da840727a23664b12d95465bf313e8e8297da31259508d1c62cc2dcea596160e21c5'
+ '0d6bc3d928cfafe4e4e0bc04dbb95c5d2b078573e4f9e0576e7f53a8fab08a7077202f575d74a3960248c4904b5f7f0661bf17dbe163c524ab51dd30e3cb80f7'
+ '2b50b25e8680878f7974fa9d519df7e141ca11c4bfe84a92a5d01bb193f034b1726ea05b3c0030bad1fbda8dbb78bf1dc7b73859053581b55ba813c39b27d9dc'
+ 'a436d3f5126c6c0d6b58c6865e7bd38dbfbfb7babe017eeecb5e9d162c21902cbf4e0a68cf3ac2f99815106f9fa003b075bd2b4eb5d16333fa913df6e2f3e32a'
+ '190112e38d5a5c0ca91b89cd58f95595262a551530a16546e1d84700fc9644aa2ca677953ffff655261e8a7bff6e6af4e431424df5f13c00bc90b77c421bc32d'
+ 'a1661ab946c6cd7d3c6251a2a9fd68afe231db58ce33c92c42594aedb5629be8f299ba08a34713327b373a3badd1554a150343d8d3e5dfb102999c281bd49154'
+ '9426829605bbb9e65002437e02ed54e35c20fdf94706770a3dc1049da634147906d6b98bf7f5e7516c84068396a12c6feaf72f92b51bdf19715e0f64620319de'
+ 'da7a97d5d3701c70dd5388b0440da39006ee4991ce174777931fea2aa8c90846a622b2b911f02ae4d5fffb92680d9a7e211c308f0f99c04896278e2ee0d9a4dc'
+ 'a50d202a9c2e91a4450b45c227b295e1840cc99a5e545715d69c8af789ea3dd95a03a30f050d52855cabdc9183d4688c1b534eaa755ebe93616f9d192a855ee3'
+ '825b9dd0167c072ba62cabe0677e7cd20f2b4b850328022540f122689d8b25315005fa98ce867cf6e7460b2b26df16b88bb3b5c9ebf721746dce4e2271af7b97')
_backports=(
)
@@ -88,138 +91,166 @@ prepare() {
# add upstream repository for cherry-picking
git remote add -f upstream ../systemd
- # merge the latest stable commit (fast-foward only to make sure
- # the verified tag is in)
- git merge --ff-only "${_commit}"
- local _c
+ local _c _l
for _c in "${_backports[@]}"; do
- git log --oneline -1 "${_c}"
- git cherry-pick -n "${_c}"
+ if [[ "${_c}" == *..* ]]; then _l='--reverse'; else _l='--max-count=1'; fi
+ git log --oneline "${_l}" "${_c}"
+ git cherry-pick --mainline 1 --no-commit "${_c}"
done
for _c in "${_reverts[@]}"; do
- git log --oneline -1 "${_c}"
- git revert -n "${_c}"
+ if [[ "${_c}" == *..* ]]; then _l='--reverse'; else _l='--max-count=1'; fi
+ git log --oneline "${_l}" "${_c}"
+ git revert --mainline 1 --no-commit "${_c}"
done
# Replace cdrom/dialout/tape groups with optical/uucp/storage
patch -Np1 -i ../0001-Use-Arch-Linux-device-access-groups.patch
}
-pkgver() {
- cd "${pkgbase/-selinux}-stable"
-
- local _version _count
- _version="$(git describe --abbrev=0 --tags)"
- _count="$(git rev-list --count ${_version}..)"
- printf '%s.%s' "${_version#v}" "${_count}"
-}
-
build() {
local _timeservers=({0..3}.arch.pool.ntp.org)
local _nameservers=(
- # We use these public name services, ordered by their
- # privacy policy (hopefully):
+ # We use these public name services, ordered by their privacy policy (hopefully):
# * Cloudflare (https://1.1.1.1/)
- # * Quad9 without filtering (https://www.quad9.net/)
+ # * Quad9 (https://www.quad9.net/)
# * Google (https://developers.google.com/speed/public-dns/)
- 1.1.1.1
- 9.9.9.10
- 8.8.8.8
- 2606:4700:4700::1111
- 2620:fe::10
- 2001:4860:4860::8888
+ '1.1.1.1#cloudflare-dns.com'
+ '9.9.9.9#dns.quad9.net'
+ '8.8.8.8#dns.google'
+ '2606:4700:4700::1111#cloudflare-dns.com'
+ '2620:fe::9#dns.quad9.net'
+ '2001:4860:4860::8888#dns.google'
)
local _meson_options=(
- -Dversion-tag="${pkgver}-${pkgrel}-arch"
-
- -Daudit=true
- -Dgnu-efi=true
+ -Dversion-tag="${_tag_name}-${pkgrel}-arch"
+ # We use the version without tildes as the shared library tag because
+ # pacman looks at the shared library version.
+ -Dshared-lib-tag="${pkgver}-${pkgrel}"
+ -Dmode=release
+
+ -Dapparmor=false
+ -Dbootloader=true
+ -Dxenctrl=false
+ -Dbpf-framework=true
-Dima=false
-Dlibidn2=true
-Dlz4=true
-Dman=true
+ -Dnscd=false
-Dselinux=true
+ # We disable DNSSEC by default, it still causes trouble:
+ # https://github.com/systemd/systemd/issues/10579
+
-Ddbuspolicydir=/usr/share/dbus-1/system.d
- -Ddefault-hierarchy=hybrid
- -Ddefault-locale=C
+ -Ddefault-dnssec=no
+ -Ddefault-hierarchy=unified
-Ddefault-kill-user-processes=false
+ -Ddefault-locale='C.UTF-8'
+ -Dlocalegen-path=/usr/bin/locale-gen
+ -Ddns-over-tls=openssl
-Dfallback-hostname='archlinux'
+ -Dnologin-path=/usr/bin/nologin
-Dntp-servers="${_timeservers[*]}"
-Ddns-servers="${_nameservers[*]}"
-Drpmmacrosdir=no
-Dsysvinit-path=
-Dsysvrcnd-path=
- )
- # meson needs a UTF-8 locale. Otherwise it displays the following error message:
- # WARNING: You are using 'ANSI_X3.4-1968' which is not a a Unicode-compatible locale.
- # WARNING: You might see errors if you use UTF-8 strings as filenames, as strings, or as file contents.
- # WARNING: Please switch to a UTF-8 locale for your platform.
- # c.f. https://github.com/mesonbuild/meson/blob/0.42.0/meson.py#L21
- if ! (echo "$LANG" | grep -i '\.utf-\?8' > /dev/null) ; then
- export LANG="$(locale -a | grep -i '\.utf-\?8' | head -n1)"
- if [ -z "$LANG" ] ; then
- echo >&2 "Unable to find a UTF-8 locale on the system"
- return 1
- fi
- fi
+ -Dsbat-distro='arch'
+ -Dsbat-distro-summary='Arch Linux'
+ -Dsbat-distro-pkgname="${pkgname}"
+ -Dsbat-distro-version="${pkgver}"
+ -Dsbat-distro-url="https://aur.archlinux.org/packages/${pkgname}/"
+ )
arch-meson "${pkgbase/-selinux}-stable" build "${_meson_options[@]}"
- ninja -C build
+ meson compile -C build
}
check() {
- meson test -C build
+ meson test -C build --print-errorlogs
}
package_systemd-selinux() {
pkgdesc='system and service manager with SELinux support'
- license=('GPL2' 'LGPL2.1')
- depends=('acl' 'bash' 'cryptsetup' 'dbus' 'iptables' 'kbd' 'kmod' 'hwids' 'libcap'
- 'libgcrypt' 'systemd-libs-selinux' 'libidn2' 'libidn2.so' 'lz4' 'pam-selinux' 'libelf'
- 'libseccomp' 'util-linux-selinux' 'xz' 'pcre2' 'audit')
+ license+=(
+ 'CC0-1.0' # siphash
+ 'GPL-2.0-or-later' # udev
+ 'MIT-0' # documentation and config files
+ )
+ depends=('acl' 'libacl.so' 'bash' 'cryptsetup' 'libcryptsetup.so' 'dbus'
+ 'dbus-units' 'kbd' 'kmod' 'libkmod.so' 'hwdata' 'libcap' 'libcap.so'
+ 'libgcrypt' 'libxcrypt' 'libcrypt.so' 'systemd-libs-selinux' 'libidn2' 'lz4' 'pam-selinux'
+ 'libelf' 'libseccomp' 'libseccomp.so' 'util-linux-selinux' 'libblkid.so'
+ 'libmount.so' 'xz' 'pcre2' 'audit' 'libaudit.so'
+ 'openssl' 'libcrypto.so' 'libssl.so')
provides=('nss-myhostname' "systemd-tools=$pkgver" "udev=$pkgver"
"${pkgname/-selinux}=${pkgver}-${pkgrel}")
conflicts=('nss-myhostname' 'systemd-tools' 'udev'
"${pkgname/-selinux}" 'selinux-systemd')
- optdepends=('libmicrohttpd: remote journald capabilities'
+ optdepends=('libmicrohttpd: systemd-journal-gatewayd and systemd-journal-remote'
'quota-tools: kernel-level quota management'
- 'systemd-sysvcompat: symlink package to provide sysvinit binaries'
+ 'systemd-sysvcompat-selinux: symlink package to provide sysvinit binaries'
+ 'systemd-ukify-selinux: combine kernel and initrd into a signed Unified Kernel Image'
'polkit: allow administration as unprivileged user'
- 'curl: machinectl pull-tar and pull-raw')
+ 'curl: systemd-journal-upload, machinectl pull-tar and pull-raw'
+ 'gnutls: systemd-journal-gatewayd and systemd-journal-remote'
+ 'qrencode: show QR codes'
+ 'iptables: firewall features'
+ 'libbpf: support BPF programs'
+ 'libpwquality: check password quality'
+ 'libfido2: unlocking LUKS2 volumes with FIDO2 token'
+ 'libp11-kit: support PKCS#11'
+ 'tpm2-tss: unlocking LUKS2 volumes with TPM2')
backup=(etc/pam.d/systemd-user
etc/systemd/coredump.conf
+ etc/systemd/homed.conf
etc/systemd/journald.conf
etc/systemd/journal-remote.conf
etc/systemd/journal-upload.conf
etc/systemd/logind.conf
etc/systemd/networkd.conf
+ etc/systemd/oomd.conf
+ etc/systemd/pstore.conf
etc/systemd/resolved.conf
etc/systemd/sleep.conf
etc/systemd/system.conf
etc/systemd/timesyncd.conf
etc/systemd/user.conf
+ etc/udev/iocost.conf
etc/udev/udev.conf)
install=systemd.install
- DESTDIR="$pkgdir" meson install -C build
+ meson install -C build --destdir "$pkgdir"
# we'll create this on installation
rmdir "$pkgdir"/var/log/journal/remote
# runtime libraries shipped with systemd-libs
- install -d -m0755 systemd-libs
- mv "$pkgdir"/usr/lib/lib{nss,systemd,udev}*.so* systemd-libs
+ install -d -m0755 systemd-libs/lib/
+ mv "$pkgdir"/usr/lib/lib{nss,systemd,udev}*.so* systemd-libs/lib/
+ mv "$pkgdir"/usr/lib/pkgconfig systemd-libs/lib/pkgconfig
+ mv "$pkgdir"/usr/include systemd-libs/include
+ mv "$pkgdir"/usr/share/man/man3 systemd-libs/man3
+
+ # ukify shipped in separate package
+ install -d -m0755 systemd-ukify/{bin,systemd,man1,install.d}
+ mv "$pkgdir"/usr/bin/ukify systemd-ukify/bin/
+ mv "$pkgdir"/usr/lib/systemd/ukify systemd-ukify/systemd/
+ mv "$pkgdir"/usr/share/man/man1/ukify.1 systemd-ukify/man1/
+ # we move the ukify hook itself, but keep 90-uki-copy.install in place,
+ # because there are other ways to generate UKIs w/o ukify, e.g. w/ mkinitcpio
+ mv "$pkgdir"/usr/lib/kernel/install.d/60-ukify.install systemd-ukify/install.d
# manpages shipped with systemd-sysvcompat
- rm "$pkgdir"/usr/share/man/man8/{halt,poweroff,reboot,runlevel,shutdown,telinit}.8
+ rm "$pkgdir"/usr/share/man/man8/{halt,poweroff,reboot,shutdown}.8
# executable (symlinks) shipped with systemd-sysvcompat
- rm "$pkgdir"/usr/bin/{halt,init,poweroff,reboot,runlevel,shutdown,telinit}
+ rm "$pkgdir"/usr/bin/{halt,init,poweroff,reboot,shutdown}
# files shipped with systemd-resolvconf
rm "$pkgdir"/usr/{bin/resolvconf,share/man/man1/resolvconf.1}
@@ -229,25 +260,13 @@ package_systemd-selinux() {
sed -i -e '/^C \/etc\/nsswitch\.conf/d' \
-e '/^C \/etc\/issue/d' "$pkgdir"/usr/lib/tmpfiles.d/etc.conf
- # add back tmpfiles.d/legacy.conf, normally omitted without sysv-compat
- install -m0644 ${pkgbase/-selinux}-stable/tmpfiles.d/legacy.conf "$pkgdir"/usr/lib/tmpfiles.d
-
# ship default policy to leave services disabled
echo 'disable *' >"$pkgdir"/usr/lib/systemd/system-preset/99-default.preset
- # add mkinitcpio hooks
- install -D -m0644 initcpio-install-systemd "$pkgdir"/usr/lib/initcpio/install/systemd
- install -D -m0644 initcpio-install-udev "$pkgdir"/usr/lib/initcpio/install/udev
- install -D -m0644 initcpio-hook-udev "$pkgdir"/usr/lib/initcpio/hooks/udev
-
- # ensure proper permissions for /var/log/journal
- # The permissions are stored with named group by tar, so this works with
- # users and groups populated by systemd-sysusers. This is only to prevent a
- # warning from pacman as permissions are set by systemd-tmpfiles anyway.
- install -d -o root -g systemd-journal -m 2755 "$pkgdir"/var/log/journal
-
- # match directory owner/group and mode from [extra]/polkit
- install -d -o root -g 102 -m 0750 "$pkgdir"/usr/share/polkit-1/rules.d
+ # The group 'systemd-journal' is allocated dynamically and may have varying
+ # gid on different systems. Let's install with gid 0 (root), systemd-tmpfiles
+ # will fix the permissions for us. (see /usr/lib/tmpfiles.d/systemd.conf)
+ install -d -o root -g root -m 2755 "$pkgdir"/var/log/journal
# add example bootctl configuration
install -D -m0644 arch.conf "$pkgdir"/usr/share/systemd/bootctl/arch.conf
@@ -264,24 +283,28 @@ package_systemd-selinux() {
package_systemd-libs-selinux() {
pkgdesc='systemd client libraries with SELinux support'
- depends=('glibc' 'libcap' 'libgcrypt' 'lz4' 'xz' 'libselinux')
- license=('LGPL2.1')
+ depends=('glibc' 'gcc-libs' 'libcap' 'libgcrypt' 'lz4' 'xz' 'zstd' 'libselinux')
+ license+=(
+ 'CC0-1.0' # siphash
+ 'GPL-2.0-or-later WITH Linux-syscall-note' # src/basic/linux/*
+ )
provides=('libsystemd' 'libsystemd.so' 'libudev.so'
'libsystemd-selinux'
"${pkgname/-selinux}=${pkgver}-${pkgrel}")
conflicts=('libsystemd' 'libsystemd-selinux' "${pkgname/-selinux}")
replaces=('libsystemd-selinux')
- install -d -m0755 "$pkgdir"/usr
- mv systemd-libs "$pkgdir"/usr/lib
+ install -d -m0755 "$pkgdir"/usr/share/man
+ mv systemd-libs/lib "$pkgdir"/usr/lib
+ mv systemd-libs/include "$pkgdir"/usr/include
+ mv systemd-libs/man3 "$pkgdir"/usr/share/man/man3
}
package_systemd-resolvconf-selinux() {
pkgdesc='systemd resolvconf replacement with SELinux support (for use with systemd-resolved)'
- license=('LGPL2.1')
depends=('systemd-selinux')
provides=('openresolv' 'resolvconf' "${pkgname/-selinux}=${pkgver}-${pkgrel}")
- conflicts=('openresolv' "${pkgname/-selinux}=${pkgver}-${pkgrel}")
+ conflicts=('resolvconf' "${pkgname/-selinux}=${pkgver}-${pkgrel}")
install -d -m0755 "$pkgdir"/usr/bin
ln -s resolvectl "$pkgdir"/usr/bin/resolvconf
@@ -292,20 +315,33 @@ package_systemd-resolvconf-selinux() {
package_systemd-sysvcompat-selinux() {
pkgdesc='sysvinit compat for systemd with SELinux support'
- license=('GPL2')
conflicts=('sysvinit' "${pkgname/-selinux}" 'selinux-systemd-sysvcompat')
depends=('systemd-selinux')
provides=("${pkgname/-selinux}=${pkgver}-${pkgrel}"
"selinux-systemd-sysvcompat=${pkgver}-${pkgrel}")
install -D -m0644 -t "$pkgdir"/usr/share/man/man8 \
- build/man/{telinit,halt,reboot,poweroff,runlevel,shutdown}.8
+ build/man/{halt,poweroff,reboot,shutdown}.8
install -d -m0755 "$pkgdir"/usr/bin
ln -s ../lib/systemd/systemd "$pkgdir"/usr/bin/init
- for tool in runlevel reboot shutdown poweroff halt telinit; do
+ for tool in halt poweroff reboot shutdown; do
ln -s systemctl "$pkgdir"/usr/bin/$tool
done
}
+package_systemd-ukify-selinux() {
+ pkgdesc='Combine kernel and initrd into a signed Unified Kernel Image'
+ provides=('ukify' "${pkgname/-selinux}=${pkgver}-${pkgrel}")
+ depends=('binutils' 'python-cryptography' 'python-pefile' 'systemd')
+ optdepends=('python-pillow: Show the size of splash image'
+ 'sbsigntools: Sign the embedded kernel')
+
+ install -d -m0755 "$pkgdir"/usr/{lib/kernel,share/man}
+ mv systemd-ukify/bin "$pkgdir"/usr/bin
+ mv systemd-ukify/systemd "$pkgdir"/usr/lib/systemd
+ mv systemd-ukify/man1 "$pkgdir"/usr/share/man/man1
+ mv systemd-ukify/install.d "$pkgdir"/usr/lib/kernel/install.d
+}
+
# vim:ft=sh syn=sh et sw=2: