summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a1906b555f89
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Jonas DOREL <jonas at dorel dot me>
+pkgname=systemd-service-pacman-download-updates-git
+pkgver=latest
+pkgrel=1
+pkgdesc="Systemd service to download packages updates"
+arch=('any')
+url="https://gitlab.com/jdorel-archlinux/systemd-pacman-download-updates"
+license=('GPL')
+makedepends=('git')
+source=("${pkgname}::git+https://gitlab.com/jdorel-archlinux/systemd-pacman-download-updates")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ #printf "latest"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "$pkgname"
+
+ install -Dm 644 pacman-download-updates.service "$pkgdir/usr/lib/systemd/system/pacman-download-updates.service"
+}