summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 10 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f7e87e7973bf..4ae9c8229dbc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Shang Yuanchun <idealities@gmail.com>
pkgname=systemtap-git
-pkgver=4.0.83.gaacee6563
+pkgver=4.0.84.g68bd23fd0
pkgrel=1
pkgdesc="provides infrastructure to simplify the gathering of information about the running Linux system."
url="http://sourceware.org/systemtap/"
@@ -15,8 +15,10 @@ provides=(systemtap=4.0)
conflicts=(systemtap)
_gitroot=git://sourceware.org/git/systemtap.git
_gitname=systemtap
-source=("git+$_gitroot")
-md5sums=('SKIP')
+source=("git+$_gitroot"
+ remove-install-exec-hook.patch)
+md5sums=('SKIP'
+ '6db56245ab316134c9a487e16ea52084')
install=systemtap.install
pkgver() {
@@ -24,6 +26,11 @@ pkgver() {
git describe | sed 's/release-//;s/-/./g'
}
+prepare() {
+ cd "$srcdir/$_gitname"
+ patch -p1 -i "$srcdir"/remove-install-exec-hook.patch
+}
+
build() {
cd "$srcdir/$_gitname"
msg "Starting make..."