summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 14 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9c4bb18340b0..21a0c0c8c1d1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,21 @@
# Maintainer: lilydjwg <lilydjwg@gmail.com>
pkgname=systemtap-git
-pkgver=3.0.213.gcc72c6a
+pkgver=3.0.240.g2c58b79
pkgrel=1
pkgdesc="SystemTap provides free software (GPL) infrastructure to simplify the gathering of information about the running Linux system."
url="http://sourceware.org/systemtap/"
arch=('i686' 'x86_64')
license=('GPL')
-depends=('elfutils' 'nss' 'python2' 'avahi')
+depends=('elfutils' 'nss' 'python' 'avahi')
makedepends=('git')
optdepends=('sqlite3' 'linux-fedora: for debug enabled kernel' 'linux-lily-debug: for debug enabled kernel')
-provides=(systemtap=2.3)
+provides=(systemtap=3.0)
conflicts=(systemtap)
_gitroot=git://sourceware.org/git/systemtap.git
_gitname=systemtap
source=("git+$_gitroot")
-md5sums=(SKIP)
+md5sums=('SKIP')
+install=systemtap.install
pkgver() {
cd "$srcdir/$_gitname"
@@ -25,14 +26,20 @@ build() {
cd "$srcdir/$_gitname"
msg "Starting make..."
+ # docs failed to build
./configure --prefix=/usr --sysconfdir=/etc \
- --localstatedir=/var --libexecdir=/usr/lib
+ --localstatedir=/var --libexecdir=/usr/lib \
+ --with-python3 \
+ --disable-docs
make
}
package() {
cd "$srcdir/$_gitname"
make DESTDIR="${pkgdir}" install
- mv "${pkgdir}"/var/run "${pkgdir}"
- sed -i 's=#!/usr/bin/python.*=#!/usr/bin/python2=' "${pkgdir}/usr/bin/dtrace"
+ cd "${pkgdir}"
+ pushd var >/dev/null
+ rmdir -p run/stap-server log
+ popd >/dev/null
+ rmdir var
}