summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 10 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f7e005b67617..d2de68cb9eab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,10 +4,10 @@
pkgname=systester
pkgver=1.5.1
-pkgrel=5
+pkgrel=6
pkgdesc="System Stability Tester is a RAM/CPU burning and benchmarking program based on calculating pi."
license=('GPL')
-arch=(x86_64 armv7h armv6h aarch64)
+arch=(x86_64 aarch64)
url="http://systester.sourceforge.net/"
makedepends=(gmp)
source=(http://sourceforge.net/projects/${pkgname}/files/${pkgname}/1.5.0/${pkgname}-${pkgver}.tar.gz)
@@ -17,7 +17,14 @@ build() {
cd "$srcdir"/$pkgname-$pkgver/cli
# only x86_64 can build both cli and lite
- [[ $CARCH == "x86_64" ]] && make || make lite
+ if [[ $CARCH == "x86_64" ]]; then
+ make
+ elif [[ $CARCH == "aarch64" ]]; then
+ make lite
+ else
+ warning "Building for arm can result in an executable that will be unstable is NOT recommended!"
+ exit 1
+ fi
}
package() {