summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 22 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a7f32b4feae5..b373be780f9e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,15 @@
# Maintainer: Leif Warner <abimelech@gmail.com>
pkgname=taffybar
-pkgver=0.4.6
+pkgver=1.0.1
pkgrel=1
license=('BSD3')
pkgdesc="A desktop bar similar to xmobar, but with more GUI"
url="http://github.com/travitch/taffybar"
arch=('i686' 'x86_64')
depends=("ghc"
+ "haskell-alsa-mixer"
+ "haskell-configfile"
+ "haskell-either"
"haskell-hstringtemplate"
"haskell-http"
"haskell-x11"
@@ -14,41 +17,43 @@ depends=("ghc"
"haskell-dbus"
"haskell-dyre"
"haskell-enclosed-exceptions"
- "haskell-gtk2"
+ "haskell-gtk"
"haskell-gtk-traymanager"
"haskell-mtl"
+ "haskell-multimap"
"haskell-network"
"haskell-network-uri"
"haskell-old-locale"
"haskell-parsec"
+ "haskell-rate-limit"
"haskell-safe"
"haskell-split"
"haskell-stm"
"haskell-text"
"haskell-time-locale-compat"
+ "haskell-tuple"
"haskell-utf8-string"
"haskell-xdg-basedir"
+ "haskell-xml-helpers"
"xmonad"
"xmonad-contrib")
+install=taffybar.install
source=("http://hackage.haskell.org/packages/archive/${pkgname}/${pkgver}/${pkgname}-${pkgver}.tar.gz"
"dynamic-compilation.patch"
- "ghc_8.2.patch")
+ "taffybar.install")
-sha256sums=('620918469d79d33067808114bdf8d4d6f5a5ae6d77ff672a37ea04ecc5e0caf5'
- 'ab4f83891b764938d4750e7a1835761028b3c8761f7f6089053b3696325851d3'
- '127746e08c91035adb38c9e6f046bd7a5377d95c9cb61d81a186e3e20f5dd808')
+sha256sums=('1632917430972d656235c4f27b485d0ea09c5df4089088281ba523380e3efda9'
+ 'ff90b6e3d05b3bb94cfc2365708bbabbb96fd9a9a4919c0face6f8d2b69037e7'
+ 'bcbdbd6d8644fda65102eb7b033b7e0b27f5a2a1f4de0d832cf7914c23c3496e')
# PKGBUILD functions
prepare() {
cd "${srcdir}/${pkgname}-${pkgver}"
- # Submitted upstream: https://github.com/travitch/taffybar/pull/247
- patch -p1 -i ../ghc_8.2.patch
- #sed -i -e "s/time >= 1.4 && < 1.7/time >= 1.4 \&\& < 1.9/" taffybar.cabal
# See https://github.com/willdonnelly/dyre/issues/5
patch -p1 -i ../dynamic-compilation.patch
- #sed -i -e 's/Dyre.ghcOpts = ["-threaded", "-rtsopts"]/Dyre.ghcOpts = \["-threaded", "-rtsopts", "-dynamic"\]/' src/System/Taffybar.hs
+ #sed -i -e 's/Dyre.ghcOpts = \["-threaded", "-rtsopts"\]/Dyre.ghcOpts = \["-threaded", "-rtsopts", "-dynamic"\]/' src/System/Taffybar.hs
}
build() {
@@ -58,7 +63,7 @@ build() {
--enable-executable-dynamic \
--prefix=/usr --docdir="/usr/share/doc/${pkgname}" \
--libsubdir=\$compiler/site-local/\$pkgid \
- -fnetwork-uri
+ -fnetwork-uri
runhaskell Setup build
runhaskell Setup register --gen-script
runhaskell Setup unregister --gen-script
@@ -73,6 +78,11 @@ package() {
install -Dm 744 unregister.sh "${pkgdir}/usr/share/haskell/unregister/${pkgname}.sh"
runhaskell Setup copy --destdir="${pkgdir}"
- install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -Dm 644 CHANGELOG.md -t "${pkgdir}/usr/share/doc/${pkgname}"
+ install -Dm 644 README.md -t "${pkgdir}/usr/share/doc/${pkgname}"
+ install -Dm 644 taffybar.hs.example -t "${pkgdir}/usr/share/doc/${pkgname}"
+
rm -f "${pkgdir}/usr/share/doc/${pkgname}/LICENSE"
}