summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a3137ae5a0e8..5fde7efff7b6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,27 @@
+# Maintainer: Mihkel Tõnnov <mihhkel@gmail.com>
# Contributor: Antonio Rojas <arojas@archlinux.org>
# Contributor: Tobias Powalowski <tpowa@archlinux.org>
-# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+# Contributor: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=taglib-extras
pkgver=1.0.1
-pkgrel=7
+pkgrel=8
pkgdesc="Additional taglib plugins"
arch=('x86_64' 'aarch64')
url="https://developer.kde.org/~wheeler/taglib.html"
license=('LGPL')
-depends=('taglib')
+depends=('taglib>=2.0')
makedepends=('cmake')
-source=("https://download.kde.org/stable/$pkgname/$pkgver/src/$pkgname-$pkgver.tar.gz" taglib-1.10.patch)
+source=("https://download.kde.org/stable/$pkgname/$pkgver/src/$pkgname-$pkgver.tar.gz" taglib-2.0.diff)
sha256sums=('fe546b4b315f3227c975fed8ea9dfc0e54fc6997fdbba2a9da7beba479229632'
- '31673efa5f655b26e5f28277bfb97b3d85d7c9f9e650a229227afe09ae2f9749')
+ 'ca199ed8a7084b948f5f3fa6c7f4763a22d5e7b587cfa596f0b26d61a6f88792')
prepare() {
[[ -d build ]] || mkdir -p build
-# Fix taglib 1.10 detection
+ # Fix build with TagLib 2
cd $pkgname-$pkgver
- patch -p1 -i "$srcdir"/taglib-1.10.patch
+ patch -p1 -i "$srcdir"/taglib-2.0.diff
}
build() {