summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..77e24f5a2cc6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# $Id: PKGBUILD 203202 2014-01-05 10:51:18Z bpiotrowski $
+# Maintainer: Nikos Fytilis <n-fit@live.com>
+# Repo Maintainer: Daniel Isenmann <daniel@archlinux.org>
+# Contributor: Carlos Ruiz <cailovirtual@gmail.com>
+
+_pkgbase=taglib-sharp
+pkgname=$_pkgbase-git
+pkgver=taglib.sharp.2.1.0.0.r69.gf8d6334
+pkgrel=1
+pkgdesc="Library for reading and writing metadata in media files for Mono - source from git for working opus files"
+arch=('i686' 'x86_64')
+url="https://github.com/mono/taglib-sharp"
+license=('LGPL2.1')
+depends=('mono')
+conflicts=(taglib-sharp)
+provides=(taglib-sharp)
+source=(git+https://github.com/mono/taglib-sharp.git)
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgbase"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/$_pkgbase"
+ ./autogen.sh --prefix=/usr --disable-docs
+ make
+}
+
+package() {
+ cd "$srcdir/$_pkgbase"
+ make DESTDIR=${pkgdir} install
+}