summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5b2372c30ce5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Martchus <martchus@gmx.net>
+
+# All my PKGBUILDs are managed at https://github.com/Martchus/PKGBUILDs where
+# you also find the URL of a binary repository.
+
+_name=tagparser
+_reponame=tagparser
+pkgname=$_name-doc
+pkgver=6.1.0
+pkgrel=1
+arch=('any')
+pkgdesc='C++ library for reading and writing MP4/M4A/AAC (iTunes), ID3, Vorbis, Opus, FLAC and Matroska tags (API documentation)'
+license=('GPL')
+makedepends=('cmake' 'doxygen' 'dia' 'graphviz' 'c++utilities')
+url="https://github.com/Martchus/${_reponame}"
+source=("${_name}-${pkgver}.tar.gz::https://github.com/Martchus/${_reponame}/archive/v${pkgver}.tar.gz")
+sha256sums=('da10bfca307e1bb473c106fb4914c6ee9d3290780f9393428af939161921b9f2')
+
+build() {
+ cd "$srcdir/${PROJECT_DIR_NAME:-$_reponame-$pkgver}"
+ cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX="/usr"
+ make ${_name}_apidoc
+}
+
+package() {
+ cd "$srcdir/${PROJECT_DIR_NAME:-$_reponame-$pkgver}"
+ make DESTDIR="${pkgdir}" install-api-doc
+}