summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9c7238c0f4e5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=tar-git
+pkgver=1.29.r24.gede0d1b
+pkgrel=1
+pkgdesc="Utility used to store, backup, and transport files"
+arch=('i686' 'x86_64')
+url="https://www.gnu.org/software/tar/"
+license=('GPL3')
+depends=('glibc')
+makedepends=('git')
+provides=('tar')
+conflicts=('tar')
+source=("git+https://git.savannah.gnu.org/git/tar.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "tar"
+
+ git describe --long --tags | sed 's/^release_//;s/\([^-]*-g\)/r\1/;s/[-_]/./g'
+}
+
+build() {
+ cd "tar"
+
+ ./bootstrap
+ ./configure --prefix="/usr"
+ make
+}
+
+check() {
+ cd "tar"
+
+ make check
+}
+
+package() {
+ cd "tar"
+
+ make DESTDIR="$pkgdir" install
+}