summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 5 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1eb428b6b40d..63983bdf81aa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Contributor: Johannes Dewender arch at JonnyJD dot net
pkgname=targetcli-fb
-pkgver=2.1.fb31
+pkgver=2.1.fb32
pkgrel=1
epoch=
pkgdesc="free branch of the targetcli LIO administration shell (iSCSI + Co)"
@@ -8,19 +8,15 @@ arch=('any')
url="https://github.com/agrover/targetcli-fb"
license=('Apache')
groups=()
-depends=('python-rtslib-fb>=2.1.fb33' 'python-configshell-fb')
+depends=('python-rtslib-fb>=2.1.fb42' 'python-configshell-fb')
optdepends=()
-conflicts=('lio-utils')
provides=('targetcli')
backup=()
options=()
install=
-source=(https://fedorahosted.org/releases/t/a/targetcli-fb/$pkgname-$pkgver.tar.gz
-target.service
-target)
-md5sums=('12db6c11794fdff7c704107d72720379'
- 'f462e9a5852346c66b77793565ddbc67'
- 'f23bd6d5d4021c29b4519e40b3b9e042')
+source=(https://fedorahosted.org/releases/t/a/targetcli-fb/$pkgname-$pkgver.tar.gz)
+md5sums=('16dc44a858025511b46858b0c5d56151')
+
build() {
cd "$srcdir/$pkgname-$pkgver"
@@ -33,15 +29,6 @@ package() {
python setup.py install --skip-build --root="$pkgdir/" --optimize=1
install -D -m 644 targetcli.8.gz "$pkgdir/usr/share/man/man8/targetcli.8.gz"
-
- # arch specific
- cd "$srcdir"
- install -d "$pkgdir/etc/target"
- # systemd
- mkdir -p "$pkgdir/usr/lib/systemd/system"
- cp target.service "$pkgdir/usr/lib/systemd/system/"
- # sysvinit (deprecated)
- install -D -m 755 target "$pkgdir/etc/rc.d/target"
}
# vim:set ts=2 sw=2 et: