summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 6 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9fbc88f8f4c7..1eb428b6b40d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,36 @@
# Contributor: Johannes Dewender arch at JonnyJD dot net
pkgname=targetcli-fb
-pkgver=2.1.fb30
-pkgrel=3
+pkgver=2.1.fb31
+pkgrel=1
epoch=
pkgdesc="free branch of the targetcli LIO administration shell (iSCSI + Co)"
arch=('any')
url="https://github.com/agrover/targetcli-fb"
license=('Apache')
groups=()
-depends=('python2-rtslib-fb>=2.1.fb33' 'python2-configshell-fb' 'python2-ethtool')
+depends=('python-rtslib-fb>=2.1.fb33' 'python-configshell-fb')
optdepends=()
conflicts=('lio-utils')
provides=('targetcli')
-replaces=('rtsadmin')
backup=()
options=()
install=
source=(https://fedorahosted.org/releases/t/a/targetcli-fb/$pkgname-$pkgver.tar.gz
target.service
target)
-md5sums=('c5993434d606ad722d6939fd519f519d'
+md5sums=('12db6c11794fdff7c704107d72720379'
'f462e9a5852346c66b77793565ddbc67'
'f23bd6d5d4021c29b4519e40b3b9e042')
build() {
cd "$srcdir/$pkgname-$pkgver"
- python2 setup.py build
+ python setup.py build
gzip --stdout targetcli.8 > "targetcli.8.gz"
}
package() {
cd "$srcdir/$pkgname-$pkgver"
- python2 setup.py install --skip-build --root="$pkgdir/" --optimize=1
+ python setup.py install --skip-build --root="$pkgdir/" --optimize=1
install -D -m 644 targetcli.8.gz "$pkgdir/usr/share/man/man8/targetcli.8.gz"