summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 12 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a790bf802734..f3f88d9a33a0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,14 +8,22 @@ url='https://people.collabora.com/~pwith/gnome-clang/'
arch=('i686' 'x86_64')
license=('GPL3')
depends=('llvm' 'clang' 'glib2' 'gobject-introspection')
-source=("https://www.freedesktop.org/software/tartan/releases/tartan-$pkgver.tar.xz")
-# Alt: https://git.collabora.com/git/tartan.git
-sha256sums=('008f8195de142900443f10d7a0a1e5a0360c1296e5684274fa39c148a161c731')
+source=("https://www.freedesktop.org/software/tartan/releases/tartan-$pkgver.tar.xz"
+ 'fix-clang-3.8.patch::https://cgit.freedesktop.org/tartan/patch/clang-plugin?id=53f9d7cbf5e0c0f9445e7e7af382a546de2f4a89')
+sha256sums=('008f8195de142900443f10d7a0a1e5a0360c1296e5684274fa39c148a161c731'
+ '785445a36752a87934d9d3d32df39cd2af8aba70c25f6f72bd34f7194b46501f')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+
+ patch -p1 < "$srcdir/fix-clang-3.8.patch"
+}
build() {
cd "$pkgname-$pkgver"
- ./configure --prefix=/usr
+ ./autogen.sh --prefix=/usr
+ sed -i 's|^#define NDEBUG|//|' config.h
make
}