summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD53
1 files changed, 28 insertions, 25 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7dffa9569e7a..eeeb7bdf8680 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,41 @@
-# Maintainer: Philip Goto <philip.goto@gmail.com>
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
+# Contributor: Philip Goto <philip.goto@gmail.com>
+_pkgname=Tau
pkgname=tau-editor
pkgver=0.11.3
-pkgrel=2
-pkgdesc="GTK frontend for the Xi text editor, written in Rust"
-arch=(i686 x86_64 armv7h aarch64)
-url="https://gitlab.gnome.org/World/tau"
-license=('MIT')
-depends=(
- xi-core
- libhandy0
- vte3
-)
-makedepends=(
- git
- meson
- rust
-)
-provides=(tau-editor)
-conflicts=(tau-editor)
-source=("https://gitlab.gnome.org/World/Tau/uploads/b5f24cd692ec0c2a2c2be460fffaf505/tau-0.11.3.tar.xz")
+pkgrel=3
+pkgdesc='GTK frontend for the Xi text editor, written in Rust'
+arch=(x86_64 i686 armv7h aarch64)
+url="https://gitlab.gnome.org/World/$_pkgname"
+license=(MIT)
+depends=(libhandy0
+ vte3
+ xi-core)
+makedepends=(meson
+ rust)
+_archive="${_pkgname,,}-$pkgver"
+source=("$url/uploads/b5f24cd692ec0c2a2c2be460fffaf505/$_archive.tar.xz")
sha256sums=('36e915de4ca906599b4ad176d4e2d625b454801a09ca0d4b0a1fbaf14915e60e')
+prepare() {
+ cd "$_archive"
+ cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
+}
build() {
- arch-meson -Dxi-core=system -Dlibhandy=enabled "tau-${pkgver}" build
+ arch-meson \
+ -Dxi-core=system \
+ -Dlibhandy=enabled \
+ "$_archive" build
meson compile -C build
}
-# check() {
-# meson test -C build --print-errorlogs
-# }
+check() {
+ meson test -C build --print-errorlogs
+}
package() {
- DESTDIR="${pkgdir}" meson install -C build
- install -Dm 644 "tau-${pkgver}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ DESTDIR="$pkgdir" meson install -C build
+ install -Dm0644 -t "$pkgdir/usr/share/licenses/$pkgname/" "$_archive/LICENSE"
}