summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 11 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c6b0b66d9ca8..befaeef5fa54 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,29 @@
# Maintainer: "Amhairghin" Oscar Garcia Amor (https://ogarcia.me)
pkgname=teams
-pkgver=1.3.00.958
+pkgver=1.5.00.23861
pkgrel=1
pkgdesc="Microsoft Teams for Linux is your chat-centered workspace in Office 365"
arch=('x86_64')
url="https://teams.microsoft.com/downloads"
license=('custom')
depends=("gtk3" "libxss" "alsa-lib" "libxtst" "libsecret" "nss" "glibc>=2.28-4")
-optdepends=("org.freedesktop.secrets")
-conflicts=("ms-teams" "teams-insiders")
+optdepends=("libappindicator-gtk3: Systray indicator support"
+ "org.freedesktop.secrets: Keyring password store support"
+ "pulseaudio: Video and voice call support")
+conflicts=("ms-teams")
replaces=("ms-teams")
-source=("https://packages.microsoft.com/repos/ms-teams/pool/main/t/teams/${pkgname}_${pkgver}_amd64.deb")
+#source=("https://packages.microsoft.com/repos/ms-teams/pool/main/t/teams/${pkgname}_${pkgver}_amd64.deb")
+source=("https://web.archive.org/web/20221130115842if_/https://packages.microsoft.com/repos/ms-teams/pool/main/t/teams/${pkgname}_${pkgver}_amd64.deb")
noextract=("${pkgname}_${pkgver}_amd64.deb")
-sha256sums=('a50de47977e81f5ba924af5c7eb9e5a76b86e2c047762bc749924cbe5ee7aa04')
+b2sums=('fb989e0f6fcf65aad52586de83a1c6da2f7a8c3d7509f3c09fec61a6a3a83660df47284c5c76964eb845441e294a0c4e29517aa0b9df1c4356efed1e1bd1a50d')
package() {
bsdtar -O -xf "${pkgname}_${pkgver}_amd64.deb" data.tar.xz | bsdtar -C "${pkgdir}" -xJf -
+ # Permissions fix
+ find "${pkgdir}" -type d -exec chmod 755 {} \;
+
# Move license
install -dm755 "${pkgdir}/usr/share/licenses/${pkgname}"
mv "${pkgdir}/usr/share/${pkgname}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}"