summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD78
1 files changed, 43 insertions, 35 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8d56028a4608..081e54e87c67 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,45 +1,42 @@
# Maintainer: Christian Hesse <mail@eworm.de>
pkgname=teamviewer-quicksupport
-pkgver=11.0.95210
-_pkgver_major=${pkgver%%.*}
-pkgrel=2
+pkgver=15.29.4
+pkgrel=1
pkgdesc='Teamviewer Quicksupport - All-In-One Software for Remote Support and Online Meetings'
-arch=('i686' 'x86_64')
+arch=('x86_64')
url='http://www.teamviewer.com/'
-depends=('bash')
options=('!strip')
-depends_x86_64=(
- 'lib32-alsa-lib'
- 'lib32-dbus'
- 'lib32-fontconfig'
- 'lib32-libpng12'
- 'lib32-libsm'
- 'lib32-libxdamage'
- 'lib32-libxinerama'
- 'lib32-libxrandr'
- 'lib32-libxrender'
- 'lib32-libxtst')
-depends_i686=(
- 'alsa-lib'
+depends=(
+ 'bash'
'dbus'
- 'fontconfig'
- 'libpng12'
- 'libsm'
- 'libxdamage'
- 'libxinerama'
- 'libxrandr'
- 'libxrender'
- 'libxtst')
+ 'gcc-libs'
+ 'glib2'
+ 'glibc'
+ 'hicolor-icon-theme'
+ 'libcap'
+ 'libgcrypt'
+ 'libgpg-error'
+ 'libglvnd'
+ 'libx11'
+ 'libxcb'
+ 'lz4'
+ 'qt5-quickcontrols'
+ 'qt5-x11extras'
+ 'pcre'
+ 'systemd-libs'
+ 'xz'
+ 'zlib'
+ 'zstd')
conflicts=('teamviewer')
license=('custom')
-source=("teamviewer_qs-${pkgver}.tar.gz::http://download.teamviewer.com/download/version_${_pkgver_major}x/teamviewer_qs.tar.gz")
-sha256sums=('57e4c5c40315e52307a2737021d6dfd02b0c8e01dfedecb805a0cdff7d09e323')
+source=("teamviewer_qs-${pkgver}.tar.gz::https://download.teamviewer.com/download/teamviewer_qs.tar.gz")
+sha256sums=('f90eb384e8e2b040cc3c93fcdc130688b5b41127b3857b344e9c937ccf381807')
prepare() {
cd teamviewerqs/
- if ! grep -q "^TV_VERSION=\"${pkgver/\~/ }\"\$" tv_bin/script/tvw_config; then
+ if ! grep -q "^TV_VERSION='${pkgver}'\$" tv_bin/script/tvw_config; then
msg "Version does not match!"
exit 1
fi
@@ -49,7 +46,7 @@ prepare() {
cd tv_bin/
- bsdtar xf archive.tar.xz
+ tar -xf archive.tar.xz
rm -rf RTlib/
rm -f xdg-utils/xdg-email
@@ -61,15 +58,22 @@ build() {
# set correct pathes in desktop file
sed -e "/^Exec=/c Exec=/opt/teamviewer/tv_bin/script/teamviewer" \
- -e "/^Icon=/c Icon=/opt/teamviewer/tv_bin/desktop/teamviewer.png" \
+ -e "/^Icon=/c Icon=teamviewer.png" \
< tv_bin/desktop/teamviewer.desktop.template \
> "${srcdir}"/teamviewer.desktop
+ rm -f tv_bin/desktop/teamviewer.desktop.template
- # duh?!
- sed -i '/UpdateBinaries/s/^/#/' tv_bin/script/tvw_main
+ # Don't try to extract tar archive during application runtime
+ sed -i '/ExtractBinaries/s/^/#/' tv_bin/script/tvw_main
+
+ # Don't clear LD_PRELOAD before running application
+ sed -i '/ CheckEnvironment/s/^/#/' tv_bin/script/tvw_main
# Yes, this is QuickSupport... But we want to use user's home directory.
sed -i '/function isInstalledTV/,/^}$/c function isInstalledTV() { return 0; }' tv_bin/script/tvw_aux
+
+ # Fix check for Qt5 XCB in libcheck script
+ sed -i '/local -r qtxcb/c local -r qtxcb="/usr/lib/qt/plugins/platforms/libqxcb.so"' tv_bin/script/tvw_libcheck
}
package() {
@@ -78,16 +82,20 @@ package() {
install -d -m0755 "${pkgdir}"/opt/teamviewer/
cp -a --no-preserve=ownership * "${pkgdir}"/opt/teamviewer/
- install -d -m0755 "${pkgdir}"/usr/{bin,share/applications,share/licenses/${pkgname}}
+ install -d -m0755 "${pkgdir}"/usr/{bin,share/applications,share/icons/hicolor,share/licenses/${pkgname}}
ln -s /opt/teamviewer/tv_bin/script/teamviewer "${pkgdir}"/usr/bin/teamviewer
ln -s /opt/teamviewer/tv_bin/script/teamviewer "${pkgdir}"/usr/bin/quicksupport
ln -s /opt/teamviewer/doc/License.txt "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
+ ln -s /opt/teamviewer/doc/{EULA_en.txt,DPA_en.txt} "${pkgdir}"/usr/share/licenses/${pkgname}/
install -D -m0755 "${srcdir}"/teamviewer.desktop "${pkgdir}"/usr/share/applications/teamviewer.desktop
+
+ for iconsize in 16 20 24 32 48 256; do
+ install -Dm644 "tv_bin/desktop/teamviewer_${iconsize}.png" "${pkgdir}/usr/share/icons/hicolor/${iconsize}x${iconsize}/apps/teamviewer.png"
+ done
install -d -m1777 "${pkgdir}"/var/lib/teamviewer
ln -s /var/lib/teamviewer "${pkgdir}"/opt/teamviewer/config
install -d -m1777 "${pkgdir}"/var/log/teamviewer
ln -s /var/log/teamviewer "${pkgdir}"/opt/teamviewer/logfiles
}
-