summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD57
1 files changed, 40 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3e176debc8e2..32395f0f93af 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,47 +1,70 @@
-# Maintainer: Dominic Meiser <dosm dot mail at gmail dot com>
-# Old Maintainer: Alex Taber <aft dot pokemon at gmail dot com>
+# Maintainer: Evandro Begati <evandroalb at gmail dot com>
pkgname=teamviewer13
-pkgver=13.1.3026
-pkgrel=3
+pkgver=13.2.153808
+pkgrel=1
pkgdesc='All-In-One Software for Remote Support and Online Meetings'
-arch=('x86_64' 'i686')
+arch=('i686' 'x86_64')
url='http://www.teamviewer.com'
license=('custom')
options=('!strip')
-provides=('teamviewer')
-conflicts=('teamviewer-beta')
+provides=('teamviewer13')
+conflicts=('teamviewer')
+# /opt/teamviewer/tv_bin/script/teamviewer_setup checklibs can check deps for each TV component:
+# TV_DMN, TV_DESK, TV_GUI
depends=(
'hicolor-icon-theme'
- 'qt5-base'
- 'qt5-declarative'
- 'qt5-quickcontrols'
'qt5-webkit'
'qt5-x11extras'
+ 'qt5-quickcontrols' # Doesn't appear in namcap, won't display UI without it.
)
+#depends_x86_64=(
+# libdepends:
+# 'lib32-libxtst'
+# 'lib32-libxinerama'
+# 'lib32-libxrandr'
+# 'lib32-libxdamage'
+# 'lib32-fontconfig'
+# 'lib32-libsm')
+#depends_i686=()
+#depends_armv7h=()
install=teamviewer.install
-source_x86_64=("https://dl.tvcdn.de/download/linux/version_${pkgver%%.*}x/teamviewer_${pkgver}_amd64.deb")
-source_i686=("https://dl.tvcdn.de/download/linux/version_${pkgver%%.*}x/teamviewer_${pkgver}_i386.deb")
-sha256sums_x86_64=('33eacc8ebeaf34aea5fa932e3d80553f358629ad454740f05aafba267b50ea93')
-sha256sums_i686=('46f1b697a113f304ff8e5792f9893319c0de6b802355e7e5fdf7dba6f4b415c8')
+source_x86_64=("https://dl.teamviewer.com/download/linux/version_${pkgver%%.*}x/teamviewer_${pkgver}_amd64.deb")
+source_i686=("https://dl.teamviewer.com/download/linux/version_${pkgver%%.*}x/teamviewer_${pkgver}_i386.deb")
+sha512sums_i686=('b44a98eef4f58b82bfd0b96edec87223a7636b2bc7822151e9ad87bcde049460c5c2327866db4fb4a4b2596466af9caac8b2302f31e99efd07539e418831143e')
+sha512sums_x86_64=('d5ec8b766e1c2eb944d2884ab4b16ae1b9358b30e8da8e0636292b74059d6feafe45a0f32c263f504b1c1c01bfdc9a840cd3a911e454473a2237b78fe6ebbd60')
prepare() {
warning "If the install fails, you need to uninstall previous major version of Teamviewer"
+ [ -d data ] && rm -rf data
mkdir data
cd data
- tar -xf ../data.tar.xz
+ for datatar in ../data.tar.*; do
+ msg2 "Unpacking $datatar"
+ tar -xf $datatar
+ done
+ sed -i '/function CheckQtQuickControls()/{N;a ls /usr/lib/qt/qml/QtQuick/Controls/qmldir &>/dev/null && return # ArchLinux
+}' ./opt/teamviewer/tv_bin/script/teamviewer_setup || msg2 "Patching CheckQtQuickControls failed! Contact maintainer"
+ msg2 "Running teamviewer_setup checklibs"
+ ./opt/teamviewer/tv_bin/script/teamviewer_setup checklibs \
+ || msg2 "teamviewer_setup checklibs failed, contact maintainer with /tmp/teamviewerTARLibCheck/DependencyCheck.log" # Currently it always exits 0
}
package() {
# Install
warning "If the install fails, you need to uninstall previous major version of Teamviewer"
cp -dr --no-preserve=ownership ./data/{etc,opt,usr,var} "${pkgdir}"/
-
+
# Additional files
rm "${pkgdir}"/opt/teamviewer/tv_bin/xdg-utils/xdg-email
+ rm -rf "${pkgdir}"/etc/apt
install -D -m0644 "${pkgdir}"/opt/teamviewer/tv_bin/script/teamviewerd.service \
"${pkgdir}"/usr/lib/systemd/system/teamviewerd.service
install -d -m0755 "${pkgdir}"/usr/{share/applications,share/licenses/teamviewer}
ln -s /opt/teamviewer/License.txt \
"${pkgdir}"/usr/share/licenses/teamviewer/LICENSE
-}
+ if [ "$CARCH" = "x86_64" ] && [ -f "${pkgdir}/opt/teamviewer/tv_bin/script/libdepend" ]; then
+ msg2 "Removing libdepend to ditch lib32 dependencies"
+ rm "${pkgdir}/opt/teamviewer/tv_bin/script/libdepend"
+ fi
+} \ No newline at end of file