summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD92
1 files changed, 40 insertions, 52 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0c049951ed16..7f2cf8851559 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,86 +1,72 @@
-# Maintainer: Niels Martignène <niels.martignene@gmail.com>
+# Maintainer: Fabian Angenoorth <fabian-ang at mailbox dot org>
+# Contributor: Niels Martignène <niels.martignene@gmail.com>
# Contributor: PyroPeter <googlemail.com@abi1789>
# Contributor: darkapex <me@jailuthra.in>
# Contributor: tty0 <vt.tty0[d0t]gmail.com>
pkgname=teensyduino
-pkgver=1.46
-_pkgver=1.46
-_arduino=1.8.9
+pkgver=1.57
+_arduinover=1.8.19
+_pkgname_loader="teensy_loader_cli"
+_pkgver_loader=2.2
pkgrel=1
pkgdesc="Arduino SDK with Teensyduino"
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="http://www.pjrc.com/teensy/teensyduino.html"
options=(!strip staticlibs)
license=('GPL' 'LGPL' 'custom')
depends=('gtk2' 'libusb-compat' 'libusb' 'java-runtime' 'libpng12' 'libsm'
- 'desktop-file-utils' 'giflib' 'avrdude')
+ 'desktop-file-utils' 'giflib')
makedepends=('git')
-provides=('arduino')
-conflicts=('arduino' 'teensy-loader-cli')
+provides=('arduino' 'teensy-loader' 'teensy-loader-cli')
+conflicts=('arduino' 'teensy-loader' 'teensy-loader-cli' 'teensy-loader-cli-git')
install="teensyduino.install"
source=('arduino.xml'
'teensy-loader.desktop'
- "git+https://github.com/PaulStoffregen/teensy_loader_cli.git#commit=d239f76f01f922e115c2661a6a3855dfc660a69c"
- "http://www.pjrc.com/teensy/49-teensy.rules"
- 'LICENSE')
-source_i686+=("http://downloads.arduino.cc/arduino-${_arduino}-linux32.tar.xz"
- "http://www.pjrc.com/teensy/td_${_pkgver//./}/TeensyduinoInstall.linux32")
-source_x86_64+=("http://downloads.arduino.cc/arduino-${_arduino}-linux64.tar.xz"
- "http://www.pjrc.com/teensy/td_${_pkgver//./}/TeensyduinoInstall.linux64")
+ "$_pkgname_loader-$_pkgver_loader.tar.gz::https://github.com/PaulStoffregen/$_pkgname_loader/archive/$_pkgver_loader.tar.gz"
+ "https://www.pjrc.com/teensy/00-teensy.rules"
+ 'LICENSE'
+ "http://downloads.arduino.cc/arduino-${_arduinover}-linux64.tar.xz"
+ "TeensyduinoInstall_${pkgver//./}_x86_64::http://www.pjrc.com/teensy/td_${pkgver//./}/TeensyduinoInstall.linux64")
+
sha256sums=('473b82156505e9bd903e4d8484e8d183f2e3bf3c1f7e29940b815929ae597b68'
- '270b55353eb438d3790c7245e5ae16ff8bac9f98cfe927d6c9f2146a34499323'
- 'SKIP'
- '031de0b26991b5a3b19c497d9c0a17f86c40c55d925b9d07d19ab89f2286469d'
- '25980feb5927b8bea8b8e999f5002e110825b1bc3d546fa902c2db5c824d33f3')
-sha256sums_i686=('f5cadd3467c183bf6f10bd981a84581fe9861cacfaad951f65f9a6f68c1a8a7e'
- '5c8e7f4bf66bee803de089628e57f1c406106de28343095da25c14388b6487af')
-sha256sums_x86_64=('ea4ea81a9b9b67d6d9eb8d27c34590749f61c45cbb7da223031a6520938d64d3'
- 'f5e906731f771f97171edfb89299ab1e052f1224c380348db8f019f85e325ac1')
-
-if [ "$CARCH" == 'x86_64' ]; then
- _bits=64
-elif [ "$CARCH" == 'i686' ]; then
- _bits=32
-fi
+ '837a865ab3bf81163c95a8a5898f9d5f0de7740a4207949bc331409cbb40faba'
+ '103c691f412d04906c4f46038c234d3e5f78322c1b78ded102df9f900724cd54'
+ '17f56b63603271e2cdae291fed347b66dfbdfd089b2847cf0b4383c877ffacfb'
+ '25980feb5927b8bea8b8e999f5002e110825b1bc3d546fa902c2db5c824d33f3'
+ 'eb68bddc1d1c0120be2fca1350a03ee34531cf37f51847b21210b6e70545bc9b'
+ '0864870639593f4b1df5e9cf7cb6eb6e8e1d9446d0745e6f448d813288ace400')
build() {
- msg2 "Installing Teensyduino"
+ echo "Installing Teensyduino"
- chmod +x "TeensyduinoInstall.linux${_bits}"
- ./TeensyduinoInstall.linux${_bits} --dir="${srcdir}/arduino-${_arduino}"
+ chmod +x "TeensyduinoInstall_${pkgver//./}_${CARCH}"
+ ./TeensyduinoInstall_${pkgver//./}_${CARCH} --dir="${srcdir}/arduino-${_arduinover}"
- msg2 "Building Teensy Loader command line"
+ echo "Building Teensy Loader command line"
- cd teensy_loader_cli
+ cd $_pkgname_loader-$_pkgver_loader
make
}
package() {
- cd "arduino-${_arduino}"
+ cd "arduino-${_arduinover}"
mkdir -p "${pkgdir}/usr/bin"
- mkdir -p "${pkgdir}/usr/share/"{doc,applications,icons/hicolor,mime/packages,licenses/teensyduino}
- mkdir -p "${pkgdir}/usr/lib/udev/rules.d"
+ mkdir -p "${pkgdir}/usr/share/"{applications,icons/hicolor,mime/packages,licenses/teensyduino}
+ mkdir -p "${pkgdir}/etc/udev/rules.d"
# copy the whole SDK to /usr/share/arduino/
cp -a . "${pkgdir}/usr/share/arduino"
- # use system's RXTX library
- ln -sf /usr/lib/librxtxSerial.so "${pkgdir}/usr/share/arduino/lib/librxtxSerial.so"
- ln -sf /usr/lib/librxtxSerial.so "${pkgdir}/usr/share/arduino/lib/librxtxSerial64.so"
- ln -sf /usr/share/java/rxtx/RXTXcomm.jar "${pkgdir}/usr/share/arduino/lib/RXTXcomm.jar"
-
- # we don't need these sources
- rm -rf "${pkgdir}/usr/share/arduino/src"
-
- # at least support the FHS a little bit
ln -s /usr/share/arduino/arduino "${pkgdir}/usr/bin/arduino"
- ln -s /usr/share/arduino/reference "${pkgdir}/usr/share/doc/arduino"
- # fix avrdude
- rm -f "${pkgdir}/usr/share/arduino/hardware/tools/avr/bin/avrdude"{,_bin}
- ln -s /usr/bin/avrdude "${pkgdir}/usr/share/arduino/hardware/tools/avr/bin/avrdude"
+ # remove bundled java to use system's java environment
+ rm -rf "${pkgdir}/usr/share/arduino/java"
+
+ # remove bundled arduino boards; they can be downloaded later in the board manager
+ rm -rf "${pkgdir}/usr/share/arduino/hardware/arduino"
+ rm -rf "${pkgdir}/usr/share/arduino/hardware/tools/avr"
# desktop icon
cp -a lib/icons/* "${pkgdir}/usr/share/icons/hicolor"
@@ -94,11 +80,13 @@ package() {
# install custom PJRC license
install -m644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/teensyduino/"
+ # install teensy udev rule
+ install -m644 "${srcdir}/00-teensy.rules" "${pkgdir}/etc/udev/rules.d"
+
# install teensy loader files
- install -m644 "${srcdir}/49-teensy.rules" "${pkgdir}/usr/lib/udev/rules.d"
ln -s /usr/share/arduino/hardware/tools/teensy "${pkgdir}/usr/bin/teensy-loader"
install -m644 "${srcdir}/teensy-loader.desktop" "${pkgdir}/usr/share/applications/"
# install command-line teensy loader
- install -m755 "${srcdir}/teensy_loader_cli/teensy_loader_cli" "${pkgdir}/usr/bin/teensy-loader-cli"
+ install -m755 "${srcdir}/$_pkgname_loader-$_pkgver_loader/$_pkgname_loader" "${pkgdir}/usr/bin/$_pkgname_loader"
}